Preform 1.9.0 required video card driver update

Just a heads up if people have problems with the latest preform crashing after startup be shure to update your drivers. Had to update the Nvidia driver and an intel driver for my laptop. Works like a champ now.

3 Likes

Still not working properly for me :pensive:

Another problem is we cannot see the orientation degree as shown in the picture below.

I have nothing but problems with new software how do I get the previous version back it worked perfectly. ?

I’ve got to agree here, I’m running a lenovo thinkpad T61 Win7 2.0Ghz/3Gb ram/SSD with an NVidia Quadro NVS 140M display adapter connected up to my Form 1+. OK, it’s not the fastest, but preform 1.8.3 ran great (as does everything else), quick to orientate objects, quick to generate supports and also to browse through the slices.

I updated to 1.9.2 and also checked the NVidia drivers were up to date and the thing now runs terrible, to the point of being unusable. The machine is well tuned so the only thing I could do was drop the resolution from 1680x1050 to 1440x900 and it ran a bit smoother, but still, trying to scroll through the slices was next to impossible, it was just going like a slug.

The update has significantly increased the demands on the PC hardware and graphics and therefore means that it now runs exceptionally slow.

I was thinking that I would now have to get a new machine but worse still is that just after updating, I started to get failed prints, the same prints I had just been running fine earlier on 1.8.3.

Hmmm, I thought it was too coincidental for the update to mess up the prints, I thought it was the resin or tray so I changed those to new ones, but no, I’ve just gone through almost an entire liter of clear v2 and nothing is working now.

So, I’ve reverted back to 1.8.3 to see if that fixes it, otherwise it’s a support ticket :disappointed: and things were going so well up to this point.

How do I get back to 1.8.3? I am under the gun to produce parts and this unworkable 1.9 is going to put me out of business!

@Dan_Keith, I’ve still got 1.8.2 for Windows and Mac, I’ll stick it up on dropbox and you can pull it down from there if that helps…

Give me a few minutes to upload…

@Dan_Keith, you should be able to pull down the windows version here:

removed as requested.

It’s v1.8.2 and works great :smile:, sorry I said 1.8.3 earlier, but it’s 1.8.2 …

And here’s the Mac version, just in case:

removed as requested.

Thank you very much I am back in business works fine. I have been bragging on the folks at formlab but now I don’t know with such buggy software. My computer is a BOXX and has lots of horse power

:smile:

Great … wow that is a high spec … makes me think that I perhaps I should update my old laptop ! but I’ll stick with 1.8.2 until they sort it out…

Hi Cheuk_Ming_Wong,

I know this change is a bit different. However, you can still change the orientation of the part by degrees by clicking on the up and down arrows. The angle will reset the new position as zero, so you are able to change the degrees relative to the current position.

There is also a better explanation of changing the orientation with the newest version of PreForm on the site here.

I’ve managed to sort out most of the problems that I was getting with 1.9.3 running under Win7.

I seemed to have hit several problems at once as whilst I was printing out a design on 1.8.2, everything went fine for the first two prints and then I decided to go to 1.9.3 and things started to go wrong.

Weirdly though, when I went back to 1.8.2 and printed the same thing and everything went ok, but I was convinced that the software update did not cause the prints to fail part way through, so I started searching for other tips or problems here in the forum.

I think that the biggest problem which just happened to occur at the same time was that whilst printing and filling up the tank, I had introduced dust onto the mirrors. When I checked the mirrors, they were peppered with dust.

So I followed the mirror cleaning guidelines and did a thorough clean using IPA and Pec Pads. Plus I used a dyson vacuum to suck out the dust (very carefully) rather than blow it around with a camera bulb as I normally do.

Next, I completely removed preform from my machine, which I didn’t do before and suspect might have caused me some problems, restarted the machine and checked everything was up to date and then I did a clean install of 1.9.3.

I’ve carried out a few small test prints and things have gone smoothly so far, which is good as one of the things I do like about this new version is the reduction in base size, that can save quite a bit of resin I’ve found, plus it makes it a whole lot easier to remove things from the build platform.

I’m going for a bigger print later, so hopefully it will be back to normal.

Still, it doesn’t run very quickly on my machine, so I’ll have to look into upgrading …

This printer is addictive !! :smile:

hi, here fab from france.
i try to install preform 1.9.3 and it’s catastrophic ! it freeze at the launch, just a micro windows with “controle quality” which block everything… i had to uninstall 1.9.3 and restore my old 1.8.2 version…
i use windows XP, is it the origin of the problem ???

Dear Kara,
As it is done intentionally, I have nothing to say. But I still prefer to old way.
Yours,
Cheuk

Dear Simon_Vowles,
How 's your test print on big models? Evreything goes fine?
Thanks.
Yours,
Cheuk

Hi Cheuk,

I have been getting much better prints now :smile: and bigger ones as well.

I know that I moaned when 1.9.3 came out and things started to go wrong, but it wasn’t just the software so I stuck at it and followed lots of tips on the forum, now I am getting great, consistent prints and have fine tuned my machine that is running 1.9.3 as well.

One of the reasons why I like 1.9.3 is the reduced support structure, it uses less resin (which is great) but also it makes the support base so much smaller that makes things much easier to remove from the build platform.

I went through a process of:

  • Thoroughly cleaning the mirrors, all of them including the galvos (very very carefully).
  • cleaning out the resin tank and made sure that both top and bottom was totally clear (although there is some slight ghosting, but no too bad)
  • filtering the resin using a paint filter

On the windows machine, I completely removed all traces of 1.8.2, restarted the machine, checked that everything was gone, then reinstalled 1.9.3. I also tweaked the graphics to get it to run a bit better and installed a faster CPU (cheaper than a completely new machine).

The down side is that it does not work on XP, I have tried to get it to work several ways but it doesn’t, so it’s Win7 and upwards, but we all know that now.

Right now I am getting consistent prints, large and small in all resins, which is great news. Along the way I got to know the Form 1+ really well, so you can tell when something isn’t quite right, whether it’s the mirrors, the resin, the tank or the way that the support structures are placed (as in, when they are clustered together, resin can pool and cause a rough surface finish).

Sorry for the long post, but if you can run Win7, the 1.9.3 version is pretty good, I know that there are some other issues out there, but I haven’t hit them yet and I am glad I stuck at it …

Cheers,
Simon

1 Like

Dear Simon,
A quick question, the Preform version should be 1.9.0 or 1.9.3? Mine is 1.9.0.
Cheuk

Hi Cheuk,

You know what, I had to do a double take when you said that as sure enough, on both my Mac and PC, Preform shows up as 1.9.0, but the downloaded files show a different version, the Mac DMG file shows up as PreForm_1.9_2.dmg and the PC install file shows up as PreForm_setup_1.9_3.exe.

A little odd, but if the ‘About PreForm’ shows up as 1.9.0 you’ve got the same as me.
Simon

Dear Simon,
I currently encounter an issue about uploading file failure/suspended. Have you ever had such issue before?

Yours,
Cheuk

Hi Cheuk,

Unfortunately, I have not had that problem. Are you using Windows 8, 7 or XP?

Looking at your other posts, I can see that you’ve had some problems already, do any files upload to the printer at all?

Simon