Preform installation/start errors... new software updates- not great

So last night I left Preform to upload a file to the printer. Fairly full buildplate, but nothing I haven’t printed before. It didn’t load anything… watching the resource manager I got about 5 minutes of heavy processor use… then it dipped down to almost nothing… still no upload. Updated to latest firmware and Preform, tried it again, got half a bar, went home. Came back in the morning, it hadn’t moved at all, the print hadn’t started. Took half the models off the buildplate, tried again, worked fine (although a little slower than what I’m used to).

Went to restart Preform today, got a buttload of errors, and no program start. I went to uninstall, and there was like 6 versions listed on program manager, none which would let me uninstall. Trying to delete the entire preform folder and reinstall. Maybe that will work? Seems like the last few updates have been filled with bugs (LCD flicker bug is the standout one).



1 Like

Oh, and it is constantly crashing now when I try and load models/ generate supports/save out files!!! 4 times in a row just this morning!!!

1 Like


okay this is getting ridiculous…