Wireless printing problem

Hey everyone,

I am trying to get my form 1+ put on my network so that more than one computer can send jobs to it. I have the exact USB sharing station recommended in the write up from Formlabs but I am not able to get Preform to recognize that the printer is connected. It shows up as a device on the computer that selects to connect to it and acts just like it is plugged into the computer in every way except in preform.

Any ideas on what might be going on? I hooked it back up to the computer for now but I need to get this figured out so I can move it off my desk and let my coworkers print their own parts.

Edit: Here is the link to the original Formlabs post:


Did you restart everything? :smiley:

Of course. Tried that multiple times over and still nothing. I went as far as removing an re-installing preform to see if it had locked the printer into a certain port the first time it was connected as some other printer softwares I have used tend to do. Still doing the same thing. I have a feeling it is something in the driver for the form 1+ that wasn’t a part of the original that is causing the error. I am going to try and access it from a different box tomorrow and see if that fixes the problem.

So I have been working on this for a few days now with no success. I have gone from using the hardware usb hub to a software based network solution and am getting the same problem on every computer I try this on. I removed the drivers that windows had assigned and reconnected everything with the same results. It appears to be something firmware related in the printer. When connected directly to the PC ti will show up as “Form1” and when connected through any kind of network it shows up as “Formlabs Form 1.” I have checked every property of the connection when it is hooked up directly and via network and it appears that when you hook it up through the network it looses a hardware ID that I will get the name of later if I get a chance. Drivers are all the same, port location and properties are all the same, and every property I have been through is the same except for hardware IDs. I am posting this in case anyone else has the same problem and if I happen to find a solution I will post it up here as well but for now its going to stay right where it and be directly linked to my box.

Hmmm, I’m sorry we haven’t had a chance to look at this more closely, Adam. I know that when we rigged it up in our office it “just worked.” Famous words, I know, but we didn’t actually have to do much in the way of troubleshooting, so don’t have a huge amount of information to share with you.

I know that other people will certainly appreciate it if you post what you do end up finding here!

Thanks Sam, I was going to see if support had any info on it later today. Let me know if you guys would like any information about the connections to see if this is something you might be able to help with. We have an FDM machine coming soon and I am going to try the same setup on it to see if that works. Maybe a couple other usb devices as well to see if it is a problem in our network infrastructure. I will keep updating as I go and I hope it can help someone else down the road.

I too had read the article and purchased the USB Share Station recommended.
I am an IT professional so I am usually pretty good at connecting devices on both the Macs and PCs as I have several of each.
I run Windows 8.1 on my PCs and OS 10.9 on my Macs.
I followed the directions and was not successful connecting to my Form+ or anything for that matter.
I tried numerous times. Went on-line for advice. Read the manuals tried and tried - still no luck.
After fooling around with it for almost a week I gave up as nothing should be this hard to hook up to a PC.
I returned the USB Share Station back to Amazon for a Full Refund and purchased a 30 foot USB extension cable to connect my Form+ and my Airwolf HD.
I didn’t think it would work even though the guy said the USB 30 foot cable was self-powered.
I connected the 30 foot cable to a USB Hub and then the Form+, the Airwolf and another new printer.
Everything is working fine.
I wish it all could be wireless but this is OK for now.
When someone finds a solution(s) to the issue(s) with the USB Share Station or if anyone knows of another wireless solution for USB devices than I will be more glad to switch to wireless.

If any know how to fix the issues or of another USB wireless solution please let me know.

Thank you,


@Sam_Jacoby, I was about to purchase one of these, but there seems to be problems for many people. Can you give us the system details that “just worked” for you guys? Operating system details, architecture (32 or 64), etc.

? With info on what works we can help ourselves.

Hey guys — I’m not trying to ignore you, here, but the mystery deepens. I asked around the office, and this was put together by a summer intern who’s no longer around. I’m trying to flush him out, but in the meantime, I do apologize. I was under the impression that it was quite a simple set-up, but it sounds like from the experience you guys have been having, that’s not the case. If we can’t figure it out, I’ll check in w/ the folks who handle USB and such, and see if there’s anything that we’re missing.

I have been looking into it a little bit and it seems that it is in the way the USB hub software processes the device. It looks like it will only allow regular printers and usb storage devices to be used with it. So with the unidentified hardware, it tries to force it to be a printer and it does not get a hardware exception that allows it to connect to Preform. it may be something that can be solved with a Preform update but for now I have given up. I will keep my eyes open for anything @Sam_Jacoby and his team can give us to fix it.

Thanks @Sam_Jacoby.

Hi guys,

Sam asked me to get back to you. I run the print farm here at Formlabs and we’ve set up a couple of these recently. The Mac we are using runs OSX 10.8.5 and seems to work fine with the IOGear Sharing Station. I have tested it with both current and past versions of PreForm.

The PC is running Windows 8.1 64 bit operating system and seems to be having some issues connecting to the IOGear Sharing Station. I will try to trouble shoot more tomorrow but just wanted to let you know we are working to figure it out.


I’m having the same problem. subscribing for updates.

Below is my current setup.

Printer: Form 1+ (ship date: 11/2014)
PC: Win7 64bit
router: netgear R6300v2

I have a netgear r6300 router with 2 usb ports. I can connect to the formlabs through the netgear usb control center. Windows, recognizes something is connected under devices and printers as “unspecified” with a caution triangle. running the auto fix option shows “unknown device doesn’t have a driver”

Preform software shows that no printer is currently connected.

In theory, this should work with routers that have USB ports and shouldn’t require the IOgear’s hub.

I’m hoping they work out the hub too. I also hope the next model printer has an Ethernet port so it can join the home network directly. Hint.

Any news on this matter? I’m running Windows 7 and am experiencing the same problems.