Firmware update : can't connect to printer

Hi there Formlabs people,

I have installed the September 4 Firmware update today (yes) , and Preform is unable to connect to the printer now.
I re-booted the printer, re-openned Preform, etc, to no avail.

How can I get printing again ?


Hey there @Olivier_Suire!

Sorry to hear about the connectivity issues you’ve been running into!

Do you mind if I ask how you’re connecting the computer to the printer? Are you doing it via Wi-Fi, USB, or Ethernet?

If you haven’t already and you’re able to, I would recommend trying the other connection method to see if that changes the behavior at all(it can also be worth restarting the computer as well).

Additionally, you’ll want to make sure your PreForm is similarly up to date because that can cause these types of errors as well.

If none of these things help solve the problem, please don’t hesitate to get in touch with our support team at the link below and we’d be happy to help out!

I had the exact same issue-

I installed the new firmware- then could not get Preform to see the printer- So I installed the new Preform- still no go.

what finally fixed it was I used UNINSTALL to uninstall the prior version and the current version of Preform.
Apparently the installer had not uninstalled all of the old version?

I then Re-installed the new version of Preform and finally the printer was recognized by Preform.

Hi all,

I updated Preform and was able to connect again.
This mis-match problem is quite irritating, because the firmware update process gives no warning that Preform should be updated simultaneously for Papa and Mama to get along fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.