Preform 2.5 Firmware Update Frozen?

I downloaded the latest (v2.5) Preform and then tried to run the firmware update on my Form1+. After 30min it is still stuck at the “Please No Not Disconnect Printer” Firmware update in progress / Printer Entering Firmware Update mode" stage and the screen on the printer is black. Any ideas?

So after waiting almost 2 hrs with no response from Preform or the printer I decided to unplug the power from the Form1+ to reset it. After powering back up I get confirmation of firmware v1.4 and “ready to print” but the printer is no longer seen by Preform. I’ve tried uninstalling v2.5 and going back to 1.9 with no luck. Then I tried v2.3.3 and still not finding my printer, as well as trying different USB ports. I should have just stayed with v1.9 since now I’m not able to print anything. DOH!

Update: unplugged power and USB for 15min then back in again. Preform now finds my printer! Whew!

Hi Mitch, indeed there are possible issues when upgrading firmwares on the Form 1+. You don’t need to worry about upgrading your firmware, PreForm will notify you if the Form 1/Form 1+ firmware needs to be updated.

I am going to go into a bit more technical depth to explain what is going on, and why this part of the process has always been a bit dodgy.

When upgrading the firmware on the Form 1+, the printer temporarily gets switched to a “DFU” mode, which means it now accepts the new firmware and reprograms itself. Because memory is very limited during that time, the screen stays black, which can be quite confusing. When it switches modes, it also gets recognized as a new USB device, which can lead to driver installs and other issues from the operating system, resulting in a timeout. One possibility here is to just unplug/replug the USB, possibly into a different USB plug. At this point, PreForm will see a printer in DFU mode, and immediately switch to the firmware upgrade.

Now the “worst” case scenario is if you started a firmware upgrade, and pulled the plug midway. Now the printer cannot leave DFU mode, since the main software has been partially overwritten. Plugging in the printer does “nothing” as the screen stays black. Don’t panic! Just plug in USB to PreForm, which will recognize the DFU mode, and merrily update the firmware correctly.

The last dodgy part is that after the new firmware has been flashed, the printer has to reset itself to leave DFU mode. This requires the USB bus to be reset, an operation that has been a notorious moving target. Depending on the USB drivers you have, this operation might have been disabled (certain Windows drivers), or not reset the bus entirely (newer OSX), and it’s a bit of a cat-and-mouse game for us. There is, however, a very reliable USB reset method, which is unplugging the cable, and if that doesn’t help, powercycling the Form 1+. After that, your newly flashed form1+ should be recognized by PreForm just fine.



Thank you for the in depth explanation. I’m now having issues with the printer randomly disconnecting while Preform is sending jobs to it which never happened in once in over a year with the old firmware and software. If I replug the USB it will appear again but then disconnect within a few minutes. I am running Windows 8.1, Preform 2.3.3 and the v1.40 firmware.

Please let me know if there is a reliable way to fix this issue. I’m currently unable to print at all due to this problem.

Thanks again,

Can you try updating to PreForm 2.6 that we released yesterday? The previous firmware was also v1.4 (we haven’t updated the Form1+ firmware since the form1+ shipped, because contrary to the Form2, the Form1+ firmware is very simple, all the magic happens in PreForm). Also, try plugging your form1+ into another USB port of your computer / rebooting your computer / using another USB cable. If the issue persists, please contact customer support.

I have never manually (or automatically) updated the Firmware on my Form1 +. Is this something that is recommended? What are the main advantages of this and how can I find out which Firmware I am currently on? Cheers

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.