Used Form 1+, Buzzing on start and always "busy"

Hi There,

Our school got a used Form 1+ donated to us. When I power it on, there is a loud buzzing noise as the display on the printer says, “Moving tank up…”. Then it clicks a few times and stops. When I try to print from PreForm, it begins communicating with the printer. The printer starts buzzing again, and then the print dialog says, Printer is busy, your printer is not available for printing. Then the process fails with an unknown error.

I have:

  1. Upgraded the firmware.
  2. Power cycled the Form 1+ multiple times.
  3. Power cycled/rebooted the PC multiple times.
  4. Tried different USB ports.
  5. Tried 2 completely different PCs.

Edit: Printer display says “Ready to print.” before I try to print.

Same thing each time. Any ideas?

Thanks, Rob

Sounds like you may need to replace the servo motor for the peel mechanism for the tank. Might want to contact support and see if you can get the part from them. I don’t believe putting the part in is all that big a deal.

1 Like

Thanks. Support says it could be that, or the motherboard. I guess we’ll see.

I agree that it sounds as if the problem is with the peel motor, but you also said you updated the firmware.

Just be sure, there hasn’t been any new firmware for the Form 1/1+ in over a year. What version did you update it to? The last firmware version is 1.40.

You can get it to display the firmware version by turning the printer off, then press and hold the power button for 3-4 seconds.

Yes, I meant I just went through the f/w update process. PreForm doesn’t actually tell you if you need to do it, it just gives you the option.

In any case, support says it’s the peel motor.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.