Formlabs Website Store Support

Stuck, can’t remove resin tank

Hi everyone, last print, my resin tank got leaked due to some cracks, and a little bit of resin got around the black metal frame holding the tank. I tried my best to clean up the resin that are around and inside with isopropanol, and it looks clean and ready for a new round with a brand new resin tank. Somehow it makes a lot of squeaky sounds and got stuck like in the picture. I believe it is the second motor on the right side that got held somehow.
I appreciate it if someone could help me in the right direction for fixing this issue.

!

update, I managed to remove the resin tank, looks like the stepper is not working as intended, it spins, but it gets stuck once I try to connect to the upper part that connects to the metal frame.

!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

hi, have you solved your motor problem?
I had the same case in 2017. At that time I contacted formlabs who had sent me a new one. This week the motor failed again.
Today formlabs apparently no longer uses these pieces. If you have a solution to find one, I am interested.