Preform not recognizing form1+

I just open a support ticket but was hoping someone here could help me out first and potentially help someone else in the future.

After plugging the computer into the printer preform does not recognize that the printer is plugged in, so there is no option to start the print. In the “printers and devices” tab in control panel form1 shows up there, so the computer is communicating with the form1. I tried rebooting the computer, re-installing an older version or preform, unpluging power from the form1 and holding the power button, but nothing seems to work. I even tried installing preform on another computer with a different USB cable with the same results. The unit seems to boot up fine and the screens says “ready to print”.

A little background on the printer…the first time I used it a few days ago preform had me update the firmware. The firmware update failed about 2 times and preform was giving me an error the device could not open DFU. I restarted preform and it suddenly started working and I was able to print, once.

bummer. a failed firmware upgrade likely left the system flash in a halflashed state (pun intended, sorry). sounds like it’s probably a brick to me, but hopefully there may be a second recovery flash that some funky button press magic can boot.


@Brad_Kellerman — support should be able to take care of you!

Brad, I have the same problem! Support has not yet offered a solution. What was the one you were given? I and perhaps some others would love to know!

I have the same issue (printer not recognized)-I can see it in the device manager but the software does not see it…
Have you found an answer to the issue? I would really want to know because we cannot make any prints…
Thank you,
Have a nice day !

I have exactly the same issue brand new machine, software uninstalled and reinstalled on two computers both can see the unit but will give the “unavailable printer detected” error. Due to this the firmware cannot be updated support ticket was submitted but no answers yet.

Matt - glad to hear you submitted a ticket. There can be a few reasons for the issue you describe, but if you are running Windows…it’s likely that the USB drivers need to be reinstalled. Support can assist for your specific case, but our general recommendation for Windows users is:

  1. Have you tried connecting the printer to another computer, with a fresh, clean PreForm installation? Preferably on another operating system, e.g. OS X?
  1. Have you had other issues with the USB ports on this computer? For example, do standard thumb/flash drives work appropriately? If not, you may need to update to Renesas USB 3.0 controller, which Microsoft only supports on Windows 8. The drivers can be downloaded at
  1. Just to check on your PreForm installation - are you using the latest release, Preform 1.9.0? If re-installing, have you run the PreForm uninstaller before re-installation? I might suggest that you uninstall, then navigate to the Formlabs folder in your system’s program files and delete that directory if there are any contents remaining, and then re-install. During installation, a bunch of status text is emitted. If you right-click on the status text, it allows you to copy the whole block to the clipboard. Can you send me this status text?
  1. If (1) fails, there is also a chance that the USB cable is the problem. The kind of cable we use is pretty standard, so if (1) ends up failing, do you have other cables of this type that you could try?
  1. Access Program Files/Formlabs/PreForm, or the appropriate folder where your program files are stored. Within the PreForm folder, there should be a usb_driver folder with Form1.inf and Form1 DFU.inf (for firmware updates) in there, which you can manually install. To manually install a driver, plug in the Form 1 and select “I will search for the driver” from the unknown hardware wizard. Select Form1.inf that you located in the usb_driver folder. Install.

…and by Preform 1.8.2, Jory actually means Preform 1.9.0 (those instructions must be out of date).

Edited! Thanks for the correction Matt :slight_smile: