New Firmware Won't Load

I’m on my fourth printer now, my second Form1+. I unpacked and installed the
new replacement printer. I turned it on, and everything seemed fine; it did
a tilt and peel, and sent the build platform to the top of the column. I
downloaded and installed the latest version of the Preform software and
opened the program. The first thing I got was a message saying that the
firmware needed to be updated, and that I couldn’t use Preform unless I
did that. So I tried to update it, but that didn’t work. It couldn’t get
into GFU mode. There was an instruction that said if that happened to
remove power, hold down the button, and turn it back on. So I tried
that, but that didn’t work either. I still keep getting the cant open
GFU mode error. Is the software really not going to work with the Build 13 firmware it’s got (which seemed to work okay, although my prints were failing)? Someone said it worked with the original Form1 firmware; do I need to downgrade to that (although it didn’t work so well and tended to spill resin)?

Andrew Werby

Just to be sure, by ‘remove power’, you mean you unplugged the cord from the wall, correct? If it is stuck in the wrong mode, it may stay there until the power is totally disconnected. And while it’s disconnected you want to actually attempt to turn it on to drain any stored power. Then reconnect everything and restart preform too.

Thanks for the help. I’d done everything except restarting Preform (who knew?), but that did the trick - it seems to have uploaded the new firmware now.


Cool :smiley: