Issues updating firmware

Has anyone seen issues updating firmware from rc-1.10-236 to the most recent version? I received a brand new Form 2 on March 28, but it has been rendered unusable because it can’t download the firmware, and there is no link to download it manually. I have tried on multiple computers with Preform and multiple networks with the same result ‘Error Checking for firmware updates’.

Hm - sounds like you’ve tried quite a few of the right steps in order to get the firmware downloaded. Here’s the link that PreForm would direct you to for the latest firmware version - rc-1.3.2-259. Go ahead and download the file, then start mid-step-5 to upload the firmware to your Form 2.

If you continue to have trouble, could you send the team a note letting us know what you’ve tried and the current status? If you receive any specific error messages, these would be helpful. From your notes, we can try to replicate the download problem and get you on the latest firmware.

Thanks for the reply. I was able to get the firmware and start printing.

On a side note, as the firmware progresses with fixes etc, will it be posted in a consistent location so those who have firewall issues, etc, can find it?

Glad that worked for you! As we release new versions, we’re definitely considering the best ways to access firmware and to know what features/changes are included through release notes. While I don’t know of any immediate plans to directly post the firmware download link, this is certainly something we’ll keep on our radar. If you have trouble accessing again, feel free to contact the Support team and we’ll be glad to help.


I got a new Form2 printer and unpacked today.
After connected the Form2 (USB) and installed preForm 2.3.1 to my Windows 10 x64 PC, notification of updating firmware to latest one appeared.
Then, I continued to update to the latest firmware, but dialogue showed some similar errors as bellow (yes, i could not print my STL file).
How do I download and update to the latest firmware version ?

Form 2
preForm 2.3.1
FirmWare rc-1.1.0-220

Error massages:
There was an error while checking for firmware updates for NostalgicWhale. Your current firmware is rc-1.1.0-220.

Error code 838: unrecognized firmware. Please contact Formlabs customer support.

Thanks in advance

I installed Preform 2.3.1 which is supposed to fix the firmware error issue so I assumed I really had old firmware. I tried to download it and got an error. Eventually I figured out how to manually download the firmware and then successfully uploaded it to the printer.

It took a while to load the tank for the first time and do the first layer of a 600+ layer build but it is running now.

Should be done in 3. 5 hours.

One question I have on the preform installation is that it says I already have a newer version of Bonjour so it skips updating it. That would not impact the firmware recognition issues, would it?


I removed preForm 2.3.1 and the installed Bonjour which was newer than that with preForm 2.3.1.
After rebooting my PC, I again installed preForm 2.3.1 and also with Bounjour in the preForm 2.3.1.
Unfortunately I am still suffering the firmware recognition issues.
Thus, Bonjour version would not affect the problem solution.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.