Firmware Update on NEW Form 2 Printer

Just installed a new Form 2 printer, second one here.
Older unit has version 1,16,8-19 Firmware
New unit has version 1.13.6-101 Firmware
Tried updating the firmware on the new Form 2 and get an error.

The Preform is 1.15.1

Open to any ideas on getting the new Form 2 Firmware updated so it’ll use the current Preform.
Hate playing around trying to get all three in balance.

I did a Factory Reset and a FIrmware Update and get the proverbial “Can’t Validate Update” message.

What are the other Firmare files that need to be installed in sequence to get this working?

Try manually uploading the files downloaded from this page :

Instead of letting preform download the file itself.

Thanks, John, but there are no download links except for the current v. 16.

I need Firmware 14 and 15 downloads. I’ll need to dig around more I guess.

Again, thanks.

Firmware files aren’'t patches,. they aren’t incremental, the last version can be installed over any older version. The “can’t validate update” seems to occur when Preform downloads the files by itself, I suspect because the file gets corrupted in my case because of the company’s firewall. Manually downloading the file removes this error for me.

I went through this on my other Form 2 and with instructions from FormLabs support I had to first install version 14 then 15 before 16 would install properly. It is also a subject of other postings on this forums that this HAS to be done this way.

Found the files, uploaded in sequence and the printer is now running properly… well, we’ll see how the first print on the unit turns out. Anyway I now have 2 Form 2 units printing at the same time.

I have had two Form 2’s running for sometime now. Probably a year at least. I have not run into any of these problems. When I got the second one, it needed to update firmware so I let it automatically do it. Same with preform and both printers. I let them update automatically do it. The only problem I have is with the dashboard only recognizing one of them while they are running.

I don’t use FormLabs resin. I use ALW resin as it’s cheaper so I run in Open Mode.

On the first F2 I had to roll-back the firmware because the new one at that time screwed up the build and welded the resin to the build place. took a hammer and steel chisel to free the pieces.

I had to then sequence the firmware updates from 14, to 15, to 16 versions. If they have been installed in sequence because you update that way they the version 16 will auto install when you run it.

But, if you do not have 14 and 15 installed in sequence then when you try and install version 16 you will get a “can not verify software” error.

Understand, this sequencing was GIVEN to me by FormLabs Support as the way I had to get the new version firmware to install. It’s not something I invented.

My newest machine came with a version 13 firmware on it. Must have been sitting in a back closet as even the shell is a different color. At least it came in 4 days from when I ordered it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.