How long should a firmware update take?

Hello - I’ve gone without printing from my Form 1+ for almost a year due to the arrival of a child. I decided today was a good day to do a test print and try to get my machine up and running again.

I updated Preform and the first thing it wanted to do, upon connecting the printer, was update firmware. That was an hour and a half ago. I cannot close Preform and the printer screen still says “waiting to print.” I have no idea if its locked up, actually updating, or what. I’m completely at a loss. Really hoping that this hasn’t bricked my printer. The current message appears to be “Please Do Not Disconnect Printer - Firmware update in process.”

Any help? Tried searching the forums and the web for anyone else having issues but haven’t seen it. I’m using a 5 year old Macbook Pro as the computer attached to the Form 1+, if that helps.

Somewhere on this forum there are a few discussions.

I do not believe the update should take anywhere that long. Being that the printer says “waiting to print”, I do not think it is updating. But siting idle waiting for a print file to be uploaded.


1 Like

What I discovered is it seems like the printer needs to be put in a special mode to actually update. Thankfully, I did not damage. What I did was turn off the printer and disconnect the power supply. I pressed and held the power button while plugging in the supply. Then the update ran in seconds. I ran a quick small model through it and it turns out that my printer still works great despite having not been put into use for a year! I just needed to stir up the resin a bit.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.