Help with Unavailable Printer Detected

PreForm gives a error message, “Unavailable Printer Detected” when I start the program. I’ve tried running the program first, then connected the USB cable from the printer, and I’ve also tried starting the program with the printer already connected via USB. The printer has the most recent version of firmware installed (rc-1.19.12-75) and I’m running the most recent version of PreForm.

I can still upload print files and start a print run, but it’s a really annoying bug that’s been present since we purchased the printer a couple of years ago.


I will go for factory reset to the machine, remove the Preform program and install it from the beginning.

To do a factory reset follow the instruction below:

To perform the factory reset:

  1. Unplug the printer from power.
  2. Reconnect the printer’s power cable to begin the bootup process.
  3. Once the Formlabs logo appears, immediately press and hold the button until “Resetting to factory defaults…” appears on the screen.
  4. Release the button. The screen will show “Factory reset complete” before initializing the printer.

To confirm a successful reset, check the uploaded jobs list. After a successful reset, the uploaded jobs list will be empty.

Keep us posted on the results.

Thanks for the suggestions!

Followed the procedures outlined, but the error message still appears.

Next step is to connect to a different computer and see if the problem resolves.

Fresh install of PreForm v3 on a different computer … no error message! So, the problem seems to be with PreForm on the original computer. There must be some data / setting / regkey that doesn’t delete when I perform an uninstall / reinstall.

1 Like


Nice work on trying another computer.
This is an IT problem, after uninstall the Preform you have to rid of the rest of the left over files. I dont know how deep you need to go in order to fix this problem so I will start from easy to hard.

  1. Uninstall the program.
  2. click on the start windows button look for “Formlabs” icon. If its there after uninstall performed, delete it.
  3. go to the Formlabs folder located in the primary disc, mostly people name it as “C”. The destination will look like this: C:\Program Files (x86)\Formlabs
  4. Delete the entire folder so when you are in Program Files (x86) you will not see the Formlabs folder anymore.

Now try to re-install the program and let me know how it went. If we still got issue, this is a deeper clean and it might be more dangerous as we need to delete some files related to windows.

Unfortunately this is a fairly generic message which is just saying PreForm wasn’t able to talk to the printer over USB. But one of the most common causes is messed up device drivers. Since it worked on a different machine, that seems like it could be the cause here.

I’m guessing you’re on Windows. Are you familiar with the program “Device Manager”. You can use that to find the Form 2 USB driver, and then there’s an “Uninstall” button that will remove the driver. If the driver was corrupted somehow, that might help.

Thanks for suggestions! I uninstalled the driver, disconnected the USB cable, and reconnected the USB cable. PreForm still shows the same error message.

My suggestion is to do a deep removal of the software as I mention above.
Sometimes a left over files after the uninstall are keeping the problem on the computer.

Have uninstalled the program, deleted program folder, performed a deep clean using CCleaner (incl. deleting unused reg keys), reinstalled PreForm v3. About 10 drivers were installed during the process. The error message still appears. The printer (Form 2) displays as disconnected when I first connect its USB cable, then after unplugging and replugging the cable, the printer displays as connected. I’ve performed a factory reset on the printer twice. The printer has the most recent version of firmware.

Hey @cdbass,

Its seems that the problem is fixex then, am I right?
You managed to connect the printer to the computer after you unplugged and plugged the USB once again (post uninstall, cleaning with CCcleaner and installed freshly).

I also have this problem! I have a very very fresh windows 10 installation…Can’t seem to figure this one. Printer is detected no problem by other machines, via wifi….but the machine I’d like to use has no wifi and it seems like the USB connection just won’t work!

Hey @nathanreilly,

Thanks for join in to the discussion and welcome to the forum!

The WiFi is a build-in feature of the Formlabs 2 (unless you are speaking on Formlabs 1) and should be visible if you enabled it from the machine of cause. If it is unabled and still not working, I’m recommending on opening a support ticket, they will be happy to assist you.

Please, keep us posted.

Unfortunately, the problem is not fixed. As mentioned in the original post, I can still upload jobs and print but the error message remains and will not go away.

You can upload to the printer from the machine that’s showing the issue? How, over USB or network?

Directly via USB cable to the printer. The printer itself is not connected to any network.

Hey @kpinhassi, thanks for the reply…i’m not sure I worded it clearly. I am having the same issue as OP…over USB. I can connect no problem using other computers and the network, but I want to connect via a machine that is not on the network, using USB.

OK, that’s really interesting. The Unavailable Printer Detected message means that it found a printer that it can’t talk to over USB. But if it is talking to the printer over USB, then something really strange is going on!

I can’t guess what it is. I guess my first guess is that something else is plugged into a USB port. Maybe a FormWash or something. But I expect you would have mentioned that.

The only other device connected to the computer via USB is a Dell Universal Receiver (Bluetooth). We do have a FormWash, but it’s never been connected via network or cable (ethernet or USB) to any computer. And, the error message has been around long before we acquired the FormWash.

Another option is a firewall or antivirus that is blocking the connection. Maybe once the machine was plugged in the very first time, there was a message from one of the computer programs and mistakenly a user approve to block this.

Based on the new info, my suggestion is to unplug the computer from the internet (literally remove the cable that connect to the computer), disable firewalls, antivirus and every other program that you have and you think it might interrupt.
and then try to connect the USB and connect the machine.

Alternatively is to go to safe-mode and try working it from there, I dont know your knowledge with computers so lets us know if disabling the protections assist at this stage.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.