Form3 onboarding: "not connected to Internet"?


#1

Setting up my new F3 today, I can’t for the life of me register it to my account.

I’ve tried wired and wireless connections, DHCP and static IP, using different DNS servers, but it won’t connect. It shows the 4 digit registration code for a couple of seconds, then flips to a “you must be connected to the Internet” error. No error codes, just failure to connect.

I grabbed the USB cable and updated the firmware (to 1.4.3) from a PC to see if that would help, but it doesn’t seem to have made any difference. Looking at the logs on my router, I don’t see it even trying to connect to anywhere that would suggest it talking to dashboard, can only see broadcast mDNS traffic, and NTP.

For the meantime I can print just fine over USB, throwing my first print job at it seemed like a much more fun idea than worrying about why it’s not working right now.

Has anyone seen this kind of onboarding failure before? Any idea how to resolve it?

S/N is ReliableRabbit.


#2

Hey @qupada!

Sorry to hear you’re having some network connectivity issues! The best way to get this issue resolved quickly is to reach out to our support team here and they’d be happy to lend a hand. :slight_smile:


#3

I have exactly the same issue with my new Form 3. It is perfectly connected to WiFi when I check settings. How to solve this problem?


#4

I was having a similar problem. My Form 3 had only an ethernet cable connection. I took the registration code to the website and tried to manually register, but it would reject the code.

I then tried a different ethernet cable and the problem was gone.


#5

I having the same problem… have no idea how to solve this


#6

Thank you nybu.
It was settled by that way.
It’s a mystery why just pulling another cable from another port on the same hub and solving it …


#7

I had a similar issue connecting to wifi. What I did was bring up the code registration page on my phone, back out, reconnect to wifi and as quick as I could punched in the 4 digit code. It registered, and continued on boarding fine after that. After getting it going in preform and updating its firmware I havent had an issue since


#8

Same here,
i’m not able to register my brand new F3 (Firmware: 1.4.4-468) on dashboard. Different cables and wifi networks doesnt solve the issue. When i press the register-button and the 4digit code displayed on the screen, the touchscreen looks like freezed. The cancle or X button having no function.


#9

Same problem, but I fixed it. You can go in the menu > connectivity,
scroll down to register your printer. There it works!
Before it was at the end of the setup “onboarding” there it switches always to check your network screen.

Cheers,
Peter


#10

I have the same problem with my 2nd printer.


#11

I have got the same bug. The screen freezed for a while and then displayed four digit code. But the Code is invalid when I input it to my dashboard. It is mysterious.


#12

My Form 3 has the same issue. In my case screen freezes for 30 seconds while trying to connect to dashboard than it returns with error message stating that I need to be connected to Internet.
I’m in contact with tech support so hopefully we’ll find solution to this problem… eventually


#13

This did the trick for me! Many thanks!


#14

Same problem here. I tried to download the logs and look at them but they appear to be encrypted or maybe compressed. Not sure. DHCP shows registration and I can print with Preform but I can’t register. The workaround with using the connectivity screen doesn’t work for me.


#15

mr81 That did the trick for me as well! Thanks for sharing!


#16

I had the same issues described above. What eventually worked for me was the following:

Connect via ethernet
Leave connection settings on automatic
Enable Dashboard Logging
Enable Remote Printing

THEN hit register to dashboard.

Those settings are disabled by default. After I turned them on the 4 digit code generated immediately when I selected Register to Dashboard. And most importantly, formlabs.com/setup accepted the code.

Hope this helps someone somewhere.

-chris


#17

That was absolutely it! They should push your answer to the top since I feel that 99.999% of the people have exactly that problem…especially when remote printing and dashboard are both disabled.


#18

This did not work for me. After trying wifi and LAN cable unsuccessfully, I had to download and install preform, connect to the machine manually from there, then allow preform to update the firmware. It seems some of these units ship with defective firmware and must be updated before it’s possible to register.


#19

I recently acquired a second Form 3 printer. I had the same problem. After a few hours of not being able to register, something changed (I do not know what!) and it worked.

I tried all the above suggestions. Have no idea what caused it to work, in the end.

There appears to be something “off” about how the Form 3 uses networks. For example, once I was done registering, I could not get PreForm to recognise my printer on the local network. I went several weeks with PreForm not being able to find the printer. After the most recent firmware update, the printer started appearing on PreForm. Again, I have no idea what the problem was. I had a service ticket open with FormLabs Support for this problem, but it seems to have fixed itself.


#20

Similar to rybu i am on my second Form3 after the first one hit a malfunction no one could solve so it was replaced under warranty after some time! The new one arrived and worked but only with an ethernet cable. We just moved house, same internet provider, same everything but when i select my printer it says disconnected! The only way i can print if with the cable from the printer to my USB. No wifi or remote printing is available as advertised and every other device in the house works except the form 3 which is sooooo frustrating and no one seems to be acknowledging or working on fixing the problem
.