Firmware Update Issue Connecting to DFU device

I am getting an error “Cannot Open DFU Device”

At this time the printer turns off and will not respond when the power button is pressed.

Guessing this is not normal.

The first thing I would try is leaving the power adapter unplugged for 30 minutes, then plug it back in. While I did not get the same error you have, my printer would turn itself off shortly after the “formlabs” logo appeared on the display and wouldn’t turn back on, and Windows would play the USB disconnect sound around the time of power loss. This method was explained to me by Formlabs support, with the reason being there’s a fuse in the power brick that can trip, and needs to be reset by removing it from power.

Also, if this is not the same problem that I had, or the problem persists, I’d contact Formlabs support and see what they suggest.

Hope that helps! ^_^)

Oh hang on, maybe this is a different issue. I think I recall seeing this when I tried updating my firmware, but I’m not certain. Try holding the power button down to where you get the serial number and such on the display, then try updating the firmware. I believe this is what I had to do to update mine, and the on-screen instructions in PreForm didn’t quite make that too clear, if I recall correctly.

Yeah nothing works. I cannot get the printer to even show the serial number by holding down the button.

Ticket submitted.

Mine had the same “Cannot Open DFU Device” error.  I unplugged it from the power-adapter for a couple of minutes and then the firmware upgrade worked fine.  Unplugging for just a few seconds wasn’t sufficient.

Yeah, I had left mine uplugged for hours and it did not matter. I currently Have a trouble ticket in with them on this and apparently I need some other update they are working on.

It does at least still print… :slight_smile:

As a referance here for others, if your printer is giving you a “Cannot Open DFU Device” error, you can manually place your Form 1 into DFU mode by taking the following steps:

  1. Unplug the power supply from the back of the printer

  2. Manually put your Form 1 into DFU mode: Hold down the power button while plugging your Form 1 back into the power supply. When you let go of the power button the OLED screen should remain black. The form 1 will likely be listed in your device manager as something along the lines of: “Form1 DFU”

  3. Open PreForm. Under the “Settings” icon select “Load Firmware”

  4. If the download is successful, your Form 1 may restart. If your Form 1 does not restart or turn on, unplug the power supply and plug it back in.

  5. While your printer is off, hold down the power button for a few seconds to check the Firmware number, it should read: 1.2c

When unplugging the printer, make sure you also unplug the USB cable, as leaving it connected can power the CPU inside the printer, and thus not lead to a full reset. If both cables are unplugged, you shouldn’t need to wait more than a few seconds before reconnecting it to do a full power cycle.

I’ve done all the things described and still get the “Cannot Open DFU Device” error. Any help would be appreciated.

Hi Lee,

could you please contact customer support with information about your operating system (version, hardware). That will help us figuring out what the issue is.

thank you!