"Could not open DFU device" with trying to update firmware

I am opening the program and is asks me to update the firmware.  When I do, I get the error above.  I tried the advice of holding the front button when plugging in power to the printer, and get the same error.  Any advice?

I used a translator.
I had the same problem.
Remove the power plug and USB.
After waiting for 5 minutes
and reconnected then operating normally.


You can manually place your printer into DFU mode and update by:

  1. Unplug the power supply from the back of the printer
  2. Manually put your Form 1 into DFU mode: Hold down the power button while plugging your Form 1 back into the power supply. When you let go of the power button the OLED screen should remain black. The form 1 will likely be listed in your device manager as something along the lines of: “Form1 DFU”
  3. Open PreForm. Under the “Settings” icon select “Load Firmware”
  4. If the download is successful, your Form 1 may restart. If your Form 1 does not restart or turn on, unplug the power supply and plug it back in.
  5. While your printer is off, hold down the power button for a few seconds to check the Firmware number, it should read: 1.3c

Hope this helps!



Thanks for the instructions, but you need to work on your reading comprehension!  ; )  As stated in the original post, I have already tried the “power button pressed when plugging in” method, as I was able to find that suggestion in a search.  However, I still receive the error when I do this process.  Do you have a further suggestion?


OK, today I unplugged the power and the USB, left them unplugged over an hour as I was doing other things.  Held in the power button and plugged both cables in, and this time the firmware “took”.  I am now on 1.3c.  Guess just keep trying if you printer is bring stubborn…


Apologies for missing that, but I’m glad you were able to get the firmware update loaded. We are looking into the update issue here internally.


Hi Mike,

I had the same problem, ran preform as administrator (right click and select “run as administrator” and that seemed to fix it for me.

However preform V1 and above are causing my box to bluescreen. Not a good situation.


I can confirm - same symptoms as others have found. Had to force DFU mode, but also had to run preform as administrator before the firmware update process would work for me. Win 8.1 if that makes a difference.

Same problem here as well. Got real scared when the update failed. Running as administrator fixed the issue (Win8.1).

Also another problem is that the printer does not restart itself once the firmware is updated. I think formlabs need to address these issues.

I had a similar battle with the update. While I’ve done many firmware updates on a lot of different equipment, this was the first firmware update I’d attempted on the Form 1. I found the process just a bit less friendly than other systems.

Some sort of indication on the display that the machine was in DFU mode would be really useful. As it is, there’s no apparent difference between the Form 1 in its “off” state and the Form 1 in the “DFU” state.

After much experimentation, I discovered that I needed to leave the Form 1 off for about 5 minutes, and then do the power on with the button held thing to get it into DFU mode.

Once the machine was in the DFU state (and once my computer had stopped complaining about not having drivers for the “Form 1 DFU device” that it now saw attached), the update itself was no problem.However, the machine looking the same when it finished the update and powered off as it did when it was in DFU mode, was not reassuring. Not knowing for sure that the firmware update had really finished and having seen too many items that have been “bricked” by the owner powering it off during the update process, was not a good feeling. It was quite a while before I found the courage to hit the power button.

1 Like

I also had this issue, but wasn’t able to get any of the existing solutions to work. Instead, I had to manually find the Form1 DFU driver and install it. Went to Preform installation folder (C:\Program Files (x86)\Formlabs\PreForm\form1_dfu_driver on my machine) and installed the “installer_x86” file. Then I opened Preform and uploaded the firmware no problem.

Hi Casey - so sorry to hear about the trouble with the DFU error, but glad that you were able to get this resolved. If you run into other issues don’t hesitate to contact our Support team. They’re here to help.

Hey Steven, no problem, thanks for the concerns. I did submit a ticket for this but solved my own problem in the interim. However, the solution that was provided to me was not terribly valuable as it was one of the existing solutions that did not work for me and I clearly stated in my request that I had tried that already. Not a big deal, just glad its resolved.

I agree with JamesBaker on a DFU mode notification shown on the machine. Would be nice to not have to trust the device manager.

Sure thing, Casey. I’m going to make sure this is input as a feature request.

Does anyone know if this method will for the Form2? I don’t see any Form 2 driver folders in the PreForm software folder.