Wifi connection frustration

So, I’m pretty much ready to give up on this printer because the wifi connection issues are so bad. I’ve tried all the standard time wasters like turning off ALL my hardware and turning it back on and praying it might work to little avail. It sees the printer every time, but it’s almost always listed as unavailable, despite showing up in my dashboard as idle, with a full print/failure list and the current tank and tray… It’ll properly connect maybe once or twice out of every twenty times I try to print and go through the idiotic time wasting power cycling process. I bought the damn thing because of the promised wifi connection and am sorely regretting it.

Any new solutions to this problem? This is unacceptable that this hasn’t been addressed for literally over a year after release as a promised feature. Seriously. I’m done with this. Fucking fix this problem, Formlabs!

The latest software/firmware release has some WiFi improvements

It’s possible though that your Wifi hardware might be at fault, it’s always worked just fine for me.

I had a few WiFi issues as well. As @Zachary_Brackin correctly stated, one of the last releases (without looking i’d say 2.6.0 / 1.8) had several WiFi fixes which, for me, dramatically increased the WiF reliability. Occasionally Preform does say that my printer is unavailable, or even more rarely it says I have 2 printers and it cannot connect to either. However restarting Preform always fixes this problem for me. But I’m sure you have done that time waster :slight_smile:

Assuming since it has been a year for you, and since you are posting here that you have not only restarted Preform but you are using the latest and greatest version (2.8.0 at the time of my writing). Also the latest firmware (1.9) which “Improved reliability for Form 2 printers connected to Wi-Fi networks with multiple access points.”

Maybe the IP address of your printer is changing? Does your router manage DHCP or a server? Can you Ping your printer? (IP Address is on your printer’s screen)

Edit: OK so I went back to look at release notes. Firmware 1.7 enabled the ability of setting a static IP Address. Have you tried assigning a static IP?

Kevin and Zach,

Thanks for the replies. I have updated everything to the current versions. After literally SEVEN power cycles on the computer, printer, and router, it finally connected and I updated the firmware. After two more, managed to get a print started. We’ll see if it helps at all. My IP has been consistent at for as long as I can remember. And it’s a simple network; modem/router only. No extenders, no weird setup procedures, no servers. The problem is the printer is two floors below me, so all this running around turning things off and on is a real hassle.

Well, only having to do two power cycles I can regretfully live with for now. But seriously, this was a promised feature and the primary reason I upgraded from my Form1. Really not pleased about how it works and am at that point of wanting to tell everyone, everywhere, that’ll listen.

Maybe since it is 2 floors down it is a simple signal strength issue? Walls, floors, microwaves, refrigerators, CNC machines, simple distance in between printer and router? Are you able to try to move it the same room (or very close to) as the router…just to test (if it is not already)? I know its not ideal, and not a permanent solution, but just to eliminate some variables.

Hi Joshua,

I’m sorry you’ve been struggling so long with wifi, but the good news is that I’ve got a couple ideas that might make it work better for you.

First, if you want to save time when forcing the printer to reconnect to wifi, you can turn wifi off and on again (printer icon -> Wi-Fi -> On/Off switch) instead of power cycling the printer. It’s much faster, and as a bonus the printer will allow PreForm to resume the print upload instead of restarting it from the beginning (the printer doesn’t allow resuming uploads if it is unexpectedly restarted). I understand that this doesn’t fix your connectivity problems, but it will make resetting your printer a lot more pleasant.

If you haven’t already, I suggest that you update your firmware to version 1.9 (released yesterday). As @Zachary_Brackin mentioned we’ve been working on improving printer connectivity, and in 1.9 we upgraded the printer’s network manager. In our internal tests printers on 1.9 seem to stay connected to wifi better; hopefully this will work for your printer too.

You mentioned that your printer is two floors below your computer – is that far away from your wireless router? Alternatively, is your computer far from the router? As @kevinduhe says, physical obstructions between your printer (or computer) and the router tend to reduce wireless signal quality. You could try moving your printer closer to the router, or if your printer needs to stay where it is you could buy a wireless repeater/extender and put it somewhere between the printer and the router.

Finally, if you haven’t tried telling PreForm your printer’s IP address (File -> Printers… -> Add Printer…) you should see if that helps. PreForm uses Apple’s Bonjour software to find printers on the local network, and I’ve noticed that Bonjour can be rather slow to discover printers on flaky wifi networks with high packet loss. As a result, you can have both your computer and the printer connected to the network and still have to wait a long time for PreForm to find the printer. If you tell PreForm the printer’s IP address then you won’t have to wait for Bonjour. (The disadvantage of this approach is that it doesn’t help if your printer changes IP addresses, but you said your printer seems to consistently acquire the same IP address).

This is all the generic advice I can think of at the moment, but if it doesn’t solve your problem I’d encourage you to file a support ticket. If you do that we can take a look at your PreForm and printer logs and give you more informed advice.

I hope this helps.

1 Like

Thanks, David. The router is actually one floor below the computer and one floor above the printer. Both have full signal and there are very few other wifi devices in the area, so we can basically eliminate that. I always have to add it via IP address. It’s seemingly never found automatically. My CAD box is running a current build of Win10 with no goofy mods. It’s a straight build with Kaspersky antivirus and it literally only runs Solidworks, Chrome, Preform, Dropbox, and iTunes.

To be fair, after I did the printer firmware update, I only had to power cycle the system twice before adding the IP address worked. That’s (sadly) a huge improvement. I’ll try sending a random print this afternoon and see how we’re doing then.

Edit: Well, I gotta say the new firmware might have done the trick. I just quit and restarted Preform twice, and the printer was there both times, and accepted print files without a hiccup.

Edit Edit: I also just slept and woke the computer (which would have normally killed any possibility of connecting to the printer) and it found the printer after just a minute or so, and uploaded a file without a problem.

Keeping my fingers crossed!

Thanks again


Glad to hear it’s working for you.

Honestly I was a tad distressed when I read Bonjour because in my prior IT experience Bonjour + Windows often equals bad news. (To be fair I transitioned out of IT work several years ago) Perhaps the latest build of Preform included an updated version Bonjour?

Whatever the case may be, I’m glad it seems to be working out for you. I’ll have my fingers cross for you as well.

  • Kevin
1 Like

Now that I am thinking about this more I wonder if having a newer version of iTunes can hurt. I wonder if it is possible that installing iTunes (which also installs Bonjour) could install a newer version of Bonjour which Preform wasn’t expecting?

Just throwing it out there as a possibility as Bonjour’s sole purpose is to provide zero config networking between 2 devices…and it sounds like that’s what your problem was.

PreForm ships with its own copy of the Bonjour SDK so I don’t think your installation of iTunes should matter – good idea though. I’ve been thinking a little in my spare cycles about how to make printer discovery faster without requiring the user to add printers manually by IP address. No promises yet, but if I’m not too busy with other features I hope to improve printer discovery in the next release or the one after it.

As Murphy’s law would have it, wireless printing is almost non-existent for me now. I am experiencing similar issues as @Joshua_Ogle did…ever since the last update. I have to disconnect the printer from the wireless network and reconnect it a couple of times for my computer to recognize the printer. Sometimes it happens after 1 time, sometimes 4-5 times. Nothing has changed on my computer or network (I am the pseudo IT guy here). It’s DHCP, had the same IP since I installed the printer and had no wireless issues for the past 6 months.

Thoughts @davidgilkaufman?

@kevinduhe just to confirm, your printer says it connected successfully to wifi and you have it added by IP address in PreForm (i.e. this isn’t a Bonjour issue)?

If PreForm disconnects from a printer it will try to reconnect, but over time it will retry less and less frequently (maxing out at one attempt per minute) to avoid flooding the network with requests for offline printers. Are you waiting long enough after reconnecting the printer to wifi to be sure that PreForm has tried to find the printer again? As an alternative test you can try to ping the printer from the machine running PreForm – if that works then PreForm should find the printer next time it tries.

If this doesn’t work for you then could you file a support ticket and upload your PreForm and printer logs? Both logs contain debugging information that’s useful for diagnosing connectivity problems and we’ll probably need that information if this advice doesn’t help.

I’ll clarify better and close by saying, I’ll watch it more closely in the coming days and perhaps open a ticket.

Monday morning I tried to print a file and the printer was listed in Preform as offline. I checked the printer and it said it was connected, listed the correct IP and said signal was strong. Power cycled the printer and nothing. Made it forget my wireless network and reconnected. At this point it worked.

Monday evening same thing.

Tuesday morning same thing as Monday morning, although it took a couple of tries of forgetting and reconnecting. In between restarting Preform. My walk between the location of the printer and Preform is roughly a 1 min walk…i cant say for sure i waited a full minute, but roughly.

Tuesday evening same thing as Monday morning, a quick forget and reconnect fixed it right away (maybe i walked slower from the printer to my computer? lol)

This morning was actually something completely different, the printer said it was not connected, although wireless was turned on. I connected and was good to go.

I realize there may be 2 different issues there…today’s disconnect may not be related to Monday and Tues. Thanks in advance @davidgilkaufman, as I said I will watch another day or so and perhaps open a ticket.

@davidgilkaufman Well, I had prints last night and this morning and the wireless worked just fine. For now I’ll just chalk it up to a fluke and open a ticket if I have any more problems.

  • Kevin

Well, here’s the least surprising thing that happened this week: The printer went back to its old shitty behavior of making me repeatedly run up and down two flights of stairs to power cycle it, the router, and occasionally my computer EVERY TIME I want to print something. Seems exactly like the same problem as @kevinduhe is having.

Well I had a week or so of no printing. Yesterday and today two consecutive print jobs and everything connected just fine. The only thing I noticed is while sending the print job to the printer, about 2/3 of the way through the progress bar reported it had lost its connection to the printer. It seemed to wait in the same spot for about 30 seconds or so, then it reconnected and continued to send the print.

I cannot say for sure whether this was the first time this has happened, just the first time I had noticed it.

  • Kevin

EDIT: just now I sent a rather large print (file) to the printer. I walked over to the printer and it said “Retrying… 45%” It eventually got to 100%, but seems like it had a connection issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.