Preform forgets my Form2

Every time I start Preform I have to re-enter the machine IP address. You DO NOT allow me to update the existing machine address in Preform so I can’t refresh that machine. I have to delete and re-create the machine.

Does that mean the IP adress of the machine is dynamic ? Wouldn’t it be simpler to just use a static adress for your Form2 ? Dynamic IP isn’t supposed to be used with “static” devices that are always connected.

I am seeing the same behavior after the latest Preform update - 2.16.0. It used to find my printer just find when the printer is using DHCP. Now it doesn’t. In addition, with a static IP, the printer will no longer show up in the online dashboard.

Try renewing the DHCP lease. It seems to have worked for me, in that I don’t have to input the password to get the printer’s WiFi to work. Whether it will make the connect more stable only time will tell.


I’m sorry to hear you’re having some issues with your PreForm/Printer connectivity. That’s definitely not what we want our users to experience.

Everything other folks have suggested here is good advice, but you’re also welcome to get in touch with our support team at the link below and we’d be happy to investigate what’s going on for you.

I will say these sorts of issues can be one of the most difficult for us to troubleshoot remotely, just because every network is different and has it’s own little foibles. That being said, we’re still happy to do our best to get things fixed for you ASAP!

Sorry, this only worked the first time, then it was back to having to remember the password.

It’s a bit easy to blame the user’s networks.
I’ve had a Form 2 for over a year, and only had to enter the password once.
Now, since the last update, it switches the Wifi Off and forgets the password everytime I put it in sleep mode.

Just find whatever silly tweaking you’ve done to how the printer connects to networks, and set it back to how it was before !

“Foibles”… meh…

I will add that the password interface is one of the worst I’ve ever seen :
-No option to actually SEE what you are typing
-No “sticky” Shift to remain in uppercase

This makes the typing of long passwords horrendously tedious.
To make it even worse, the first entry ALWAYS fails for some reason.

Really pissed off here…

I will agree with the others in that I have connectivity issues with my printer after the latest update. After a couple of years of working perfectly now quite often I have to go through efforts to get the printer available in Preform.

I agree with the others on here- after the update the printer switches off WIFI every time the printer is switched off, you need to switch it back on and then reenter the password.

Obviously a bug in the latest version of software… How long before Formlabs acknowledges it and corrects is a question akin to how long is a piece of string

To be fair the two issues are different, at least in how they are presented.

One is about the printer connecting correctly to the router, but since the IP that is getting assigned to the printer is changing between each connection it’s not straightforward for Preform to reconnect to it. I think @DKirch’s answer was addressed at this issue.

The second is the printer itself seemingly having trouble remembering the wifi password.

The issue addressed in this thread definitely has to do with network config, while yours (as you presended it in your other thread) probably has more to do with Formlabs as you have suggested.

Hi John,

Well, for the issue I am seeing, I had the following answer by e-mail :
“We are aware that this is an issue with the latest firmware release and we are working to resolve this as quickly as possible.”

In my case, putting the printer to sleep would both :
-Switch WIFI off, but not put it back on when printer is switched on
-Lose all WIFI passwords

This proves that there is probably a very lenient test procedure at FORMLABS before releasing a new firmware.

I am not saying that your complain isn’t real, on the contrary, I certainly believe there is an issue with the wifi password. I only mean to say that the issues in this specific thread is probably not the same and is most likely related to / can be solved through network configuration.

That’s not what is happening. It is that the printer is dropping the WiFi connection. Other, more distant, computers are keeping their connections up, while the printer drops its after a short period. This, of course, could be a router problem. but it is difficult to test. The IP on connection to the printer is always the same on connection.

Any peripheral that remembers its own wifi password is not secure.

I have managed to get the printer to connect with the wifi router and the connection has been solid for the last 24 hours.

What did I do? simply rebooted to router.

Perhaps Support should add this to the ‘Things to do when the wifi goes pear-shaped’ list. They probably need to put it just above ‘Sacrifice a chicken to the wifi Gods’ on the list.

1 Like

Static IP addresses and Wifi have a problem if the printer is rebooted. The settings are lost, and It appears the printer does not register with the DNS properly so Preform can locate the printer. I went back to DHCP, using a wired connection, and used IP binding on the DHCP server (or your router) to reserve the DHCP address for the printer. This is similar to using a static IP, but the printer is asking for an address through DHCP rather being told to use a particular address. This setting sticks through a reboot and with the DHCP registration happening, it appears Preform can then find the printer.

Note that Preform may still be slow to pick up the printer, often telling me it is offline. This usually occurs if the printer was put into sleep mode. Eventually Preform finds the printer using this method by the time I am done setting up a print in Preform. As some have suggested, refreshing the DHCP lease will do the same thing but in my tests, for some reason this didn’t always work, although it should.

The key point is that I never needed to do this before the latest firmware update. This seems to be the common element in this thread. I opened a support ticket, and Formlabs responded that it is aware of the issue and is working to resolve it.

Again, my fix above pertains to wired connections only.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.