Support generation in PreFrom doesn't work


I unpacked and installed a new Form1+ yesterday. There seems to be a problem with support structure generation in PreFrom. When I press the button, the progress bar starts but never goes until the end and I never see any support structures. I have tried a couple of downloaded models and the Test print file from Formlabs, but never seen any support.

I’m running on Windows 7 as an admin.




Do you have a simple test form file which you have saved after generating supports? This way we’ll be able to see if it has something to do with your graphics. If we can see the generated supports we know it’s not the program. In most cases it’s a driver fix.

The model can be anything. Just create a cube in a 3d program. Save it as stl, generate supports in preform, save it as a form file and share the Dropbox link.

It is strange that you say it never reaches the end though… Not sure if it has anything to do with it, but what the percentage use of your hard disk, memory and processor when generating supports?

Thanks Alex,

I downloaded a cube stl file from thingiverse and saved it in PreForm before and after generating supports. Here’s the link to both:!43191&authkey=!AMdL29kliIQa2O0&ithint=folder%2C

I’m running a rather old Core2 Duo system, and the CPU usage of both cores is at 100% when generating supports. There’s plenty of available memory during that, about 2 GB.

Well @Markus_Haapala, both files don’t have supports unfortunately. I’m able to generate supports so it’s not the file either.

Have you tried installing preform on a different computer that has a better CPU? I’m running preform on a laptop (about 1 year old) and don’t have any CPU/GPU or hard disk issues when generating supports. It takes about a second to generate supports on this cube… Perhaps it really is the cpu which is having trouble with preform.

Preform is a pretty demanding program. When I have multiple preforms running in the background (10), my computer gets really slow. Any other program doesn’t do that.

Hopefully you have another computer to test this on. It’ll be the easiest way of seeing your computer will need updating to better hardware!

BTW, even if you close preform properly, it sometimes stays working in the background. Check your taskmanager you don’t have multiple running. That wouldn’t help the situation ;).

I installed PreFrom on my home computer and everything seems to work well. Obviously it’s then the computer at work, which is the problem. Luckily we already ordered a new computer for 3D printing purposes.

Thanks a lot for the quick help.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.