"Resin Sensor Error"

After not being able to print because of the resin sensor error from my new out of the box printer, I tried installing the firmware update which took about a week with the support team to get to work without a decryption error…
Now I’m finally up to date on the firmware and still have the Resin sensor error. I have already a tried resetting the tank and the build platform. I also tried placing the resin cartridge in in a counterclockwise manner as described on the formlabs website.
How have any of you fixed this error since the support team has been completely unhelpful in getting my Form 2 to print.

I’m very dissatisfied with this this product and the support team.

Posts like the above and others, really make me wonder why the reliability of the Form2 can not be locked down . You think that this would be priority number one. . Of course I dont know the stats of the percentage of users that have had issues like the above poster and I also know that many people rave about their printers, but post like these seem to appear on a consistent basis. It may be a small percent. I guess this is the nature of the beast they created and they need more time to fully tame it?

I also have this error. We bought 2 printers and one is working fine but the other one is not working at all because of the resin sensor error. We couldn’t print anything with it, and we tried all the recommended actions including firmware update and got past the decryption error but still nothing. Eventually we are going to send the printer back to them :frowning:

I have this error as well. Our first print used the black v3 resin and it printed just fine.
Now we have the White v3 resin and i replaced the resin tank for a new one. Then started a print but was instantly faced with this error. The tank was able to fill but the sensor error was keeping appearing.
I took out the tank and had a look at the sensor there was no resin or anything on it.
I gently pushed the tank back and attempted to print again, no success.
I restarted the print and for some reason the form2 was filling the tank again, which afterwards it started to print. It looked hopeful. But at layer 15/449 it stopped and gave me an error again.
I tried to do the same things as before except starting the print over again, but no success.
I can’t see if the printer spilled any resin somewhere.
I have checked the resin level and its slightly beneath the top black line on the tank.
I have manually filled the resin tank above the maximum, but did not help. Then i removed the resin again so it was on level again.
I cleaned the sensor and tank several times, I even tried a completely new tank. No success.
I prefer not to stop this print but i am getting stuck at troubleshooting this issue.

Disappointed to hear that our team wasn’t able to get this corrected for you and if you keep working with our support team, we’ll work to get this resolved. As far as troubleshooting goes, starting out with updating the firmware is a great first step. If that doesn’t seem to correct things, cleaning the sensor with IPA can help. You might also try slowly inserting the tank until you see the ‘tank inserted’ message flash and then not inserting it any further. @Dragos @MrMark The above might be helpful for you as well and our support team is great for additional steps.

It’s important to note that the forums aren’t necessarily a representative sample and many people come here for troubleshooting. Our support team closely tracks all of the instances of a particular error so that we can quickly identify and correct issues that are causing trouble for a large subset of users. Reliability is a top priority and we’ll continue making improvements both with new materials and software updates.

[quote=“Frew, post:6, topic:15733”]
It’s important to note that the forums aren’t necessarily a representative sample
I think they are a representative sample if they own a Form labs machine. Perhaps you meant to say a small representative sample. Of course it is unknown to a forum reader what percentage of total machines any issue posted about actually represents. But my guess would be that its fair to say that there is a slight issue with getting all the bugs out of the printer. I am not judging this either way, Its great to see Formlabs doing what they do. Just my observations and comments.

Hi all,

I’m checking in as another user who is experiencing the resin sensing issue. My next step will be to open a support ticket. Here’s a description of what I’m seeing:

  • Issue has happened on 3 out of 15 prints
  • Firmware and PreForm software both updated
  • Each time, the print starts fine. A few hours in, the resin tank is overfilled and the print stops.
  • Resin sensing error message
  • Even after print has stopped; the cartridge is still dripping resin into the tank
  • I don’t think that this is a leaky bite valve, since I’ve had successful prints and unsuccessful prints on the same bottle
  • After removing the cartridge, I can clearly see that the bite valve trigger is holding the bite valve open
  • I’ve tried removing and resetting the tank
  • I’ve tried cleaning the level and tank sensors with IPA
  • It seems that if I empty some resin out of the tank and resume, the print will work

I’d recommend opening a ticket for this before continuing printing. The bite valve should not remain open for the duration of a print and this could lead to issue like resin overflows. Thanks for the troubleshooting you’ve done so far and linking this thread as well as your PreForm and Firmware versions in the ticket would be a big help!

@Frew - good call. I went ahead and contacted support, rather than risking an overflow. Declan did a great job helping me out, and a new replacement part is on the way.

It’s great to see this level of support, in contrast to some other start-up print companies. For the record; aside from this issue, the prints from my machine have been flawless.

Closing out this thread -

Support sent me a new cartridge floor assembly, which includes the resin dispensing servo. This resolved my problem, I’ve since completed a few prints without issue. It was about a 30 minute job to install the cartridge floor.

I also have the same problem with the Form 2 printer new out of the box printer.
I am a product design engineer and have tried everything at my control and have no luck.
Hopefully on Monday Formlabs will have a fix. Everything else looks great.

We bought a Form 2 and tried to make some printouts.
After a lot of “Resin Sensor” Errors" a black printout worked.
Than we installed a new tank and a Tough Cartridge - No resin flows into the tank …
So we tried the “Durable” Cartride - No resin flows into the tank.


No answers from the support and the german sales team (should I buy a prof support plan?) coudn’t be reached by telefon today and no answers by mail …

We expected a working product . :frowning:

What should we do?

THanks for help

Have you tried poking at the cartridge’s valve ? I can imagine it not opening well the first time, just like the valve in some camelbak products which looks nearly identical.

Check if the bite valve on the bottom of the cartridge isn’t glued. If you press the sides, it should open easily. I’ve had quite a few on the past weeks like that. Just grab something sharp and open it manually - it will work just fine! (the tweezer from the finishing kit works well). Be careful as it will drop a little bit of resin.
If the problem persists, you might have a faulty resin dispensing motor.


yes, I pressed them a little together and the lips opend,
This works - on both cardridges.

seems to be this :frowning:

I am another new user with the same problem. Doesnt seem to be a resolution for this design flaw. The support/chat window is equally non-responsive for me(during biz hours). Im just chiming in to add to the disappointment stats.

I was going to buy a Form2 but I saw unresolved issues like this on the forums while I was investigating. A client finally sent me one and I am glad that I never bought one for just the above reason.

Just an update for you all…
I can not believe what I have received. After over a month trying to fix with the support team what appeared to be a broken machine (that I just purchased new), I was approved for a return. Upon opening the box today expecting a new machine, I am welcomed with something that appears used and or refurbished. This is completely unacceptable. The printer has resin droplets all over the enclosure, visible spills, and an overall dirty machine. This has been the worst purchase I have ever made and this type of service is completely unacceptable. I am beyond upset at this point.

This was a mistake on our end and I reached out to our support team to make sure this gets resolved. You should have an email from a member of our team and a visibly damaged printer certainly doesn’t meet our refurbished specifications nor should it be the expected resolution to a printer that’s sent in for repairs. It sounds like you were meant to receive a new unit and we’re looking into why that didn’t happen here.