Resin sensor error again and again!

I received the “Resin Sensor Error” pretty much straight out of the box. I have contacted support, followed their instructions, and it’s still giving me issues. I have been able to complete one print, but on anything else I’ve tried, I have received this same error. Also, if I can get the printer to start a print, that doesn’t guarantee the print will finish without the resin sensor error coming up. My last print was 17 minutes away from finishing when the error popped up. I tried to alleviate the problem with no success. Now, I can’t even get a print to start because of this error. Getting very frustrated. Help!

1 Like

Try Open Mode for a while. You’ll need to close the vent cap on the Resin Cartridge after the tray has enough resin. Might need to pour it into the tray but you should be able to get your prints done. I’ve done this to use up resin and the heater issue isn’t a problem as the machine itself generates some heat from the electronics. The prints I did this way with FL resin work out ok.

That’s the thing though. If I wanted to operate in open mode, I would have bought a different machine. I’d like the printer to operate how it should. I’m not one to complain about minor things, but this is functionality we’re talking about. I just want it to work.


Agreed that compromising with Open Mode shouldn’t be necessary on a new machine. Have you been able to get in touch with our support team? We’ll help to identify the root cause of this.

I have spoken with support. The adjusting of the leveling screws alleviated the problem and allowed me to finish my first print. However, the very next print, it happened all over again. Now, no matter how much I adjust the screws, my machine won’t even start a print. The most recent response from support, after they reviewed my latest printer diagnostics, have pointed me BACK in the direction of the screws, again. I’m not trying to be harsh, but the customer shouldn’t have to double check that printer was assembled correctly. It’s really frustrating that a $3500 machine doesn’t work out of the box.


i am having the same problem.
Lost two large prints when it went into a resin sensor error repeatedly.

I cleaned the sensor- i leveled the printer- I literally went thru the resin with a fine tooth comb to verify that there were no globs of semi cured resin… i even tried shoving the tank in slightly askew as Formlabs recommends.

however- being persistent- I tried printing it again- it estimated an 11 hour 30 minute print time. Started it at 11 pm and went to bed.
I woke up to the sound of the Form2 printing away… but upon looking at the log, saw that it had had a conniption fit of Resin Sensor Errors around 4 in the morning. 27 errors in a row. each error had resulted in a 5 minute printer pause, and then an attempt to resume printing ( automatically- I was asleep ) - but now it was printing fine and the part looked no worse for having been stopped for two hours.
it printed merrily along from 6 am till 11 am- and then it went into another conniption fit of resin sensor errors.
frustrated, I just left it- not hitting abort or nothing…

six hours later- it resumed printing… on its own, after 73 additional printer sensor errors and a five minute pause after every one.
The print came out fine, but was a 21 Hour build.

The thing is- it’s a crappy sensor design.
my experience shows there was NEVER any problem with the feet, the tank or the resin… it was strictly Formlabs Sensor design, programming, or build components causing this issue,

There is no excuse for it creating these error messages doing the ONE task it ought to be able to do to automate resin dispensing.
I didn’t want a HOBBY printer i had to baby sit and constantly hand top the resin tank on 20 hour prints. The cartridges themselves are NOT designed to facilitate hand dispensing.
I only bought this BECAUSE of these features.

FormLabs needs to ADDRESS this issue and they won’t unless everyone demands they solve it.
that, or stop advertising it as auto-filling.

until then, next time- try what i did- DO NOT ABORT THE PRINT. Just let the thing keep on trying to sense resin for the hour or six it will take and see if it ultimately completes the print.

1 Like

Okay- for those having interminable resin sensor errors… I think i may have figured out a cause.

When I first leveled the printer- I got the bubble dead center… but the bubble kept jerking left to right- out of level…
Alternating between telling me to raise the right side, or raise the left side. Each time flashing orange.

Because of the suggestion to only use the printer in a well ventilated area- and the fact that I was putting it inside a cabinet- I had installed a whisper quiet ventilation fan in the cabinet. When I turned off the fan, the printer level bubble was steady, at dead level. Turn it back on… and it would jerk back and forth again.

Formlabs support verified that the accelerometer they used could be affected by EMI,…

So last night I wondered if their resin sensor could also be affected. I turned off the fan and ran a 15 hour print.
The print ran on time without a single resin sensor interruption.

I don’t know if EMI was the reason… maybe I just happened to insert the resin tank JUST RIGHT… for once.
But I am suggesting that anyone else suffering recurrent Resin Senor Errors try and look for sources of EMI in or near their printer and eliminate them.
Things like fans, flourescent lights, and other electronics that might be noisy in just the right wavelength to mess with an electronic sensor.

Please report back to this thread if turning those kinds of things off shows any improvement in your Form2 running without error.

my enthusiasm was for naught.

Despite suddenly running a 15 hour print without error…
my very next 10 hour print ran for 3 hours, then suffered 91 consecutive resin sensor errors.

it finally successfully resumed 8 hours later. and is still running… but I assume it will suffer additional resin sensor errors.

Although the Form 2 can EVENTUALLY get the print produced… i have determined that each Long pause of hours leaves a definitive Mark on the print in the form of a significantly more noticeable printer layer.

for figurative prints, these would be unacceptable flaws.

Anyone else have a solution other than shutting off the automatic features I bought this thing for?

After support realized they had already pointed me in the direction of the screws once before, They have offered to send an additional resin tank to ensure that isn’t the problem. I appreciate their willingness to try to make this right, but seeing as how multiple people on this forum have the same issues, I’m not holding my breath hoping this will fix the issue. Don’t get me wrong, if it does then I’ll be eccstatic. We’ll see what happens.

Been having the same error since the last update. Contacted support, they suggested adding tape to the bottom of the cartridge to lift it a 1mm or so to make proper contact. That didn’t work. It’s now been 3 days since support has last replied to me concerning this. I’m trying to be patient but this is really frustrating, I’m losing money everyday this printer isn’t running the way it should.

The sensor is faulty or the software running it is faulty.
It has NOTHING to do with the tank, the feet, the level, junk in the resin nor any other suggestion made by Formlabs as to what WE are doing wrong in running the printer.

The prints I am running are running fine for hours, then suffering hours of resin sensor errors, each time attempting to resume but failing due to sensor error… but THEN unaccountably resuming printing.
i.e.- if there were something wrong with tank or resin, then it should STAY in error if I do nothing to remedy the issue.

I leave the thing alone and it always eventually resumes printing.
The last part I ran estimated at 10:44- it took 33 hours to print. It stopped yesterday at 2 in the afternoon… and sat there trying to resume until 7 am this morning… when it finally resumed printing and finished the part- with bad lines at every interruption in printing.

once more- this could not happen if the resin sensor errors were VALID. if something in how the machine was set up was wrong, and I did nothing to correct it, then the machine should be unable to resume printing.

I would LOVE to just hear Formlabs admit its an issue and they are working on a fix.

Out of curiosity, when did you guys purchase your cartridges? I got mine in late November. The cartridges I had befire that worked perfectly fine. maybe this is just a batch of faulty sensors or cartridges?

1 Like

I was finally able to get a print to actually start. 1 hour 51 minute print time, and I made it an hour before the newest resin sensor error popped up. I really don’t want to resort to the “Office Space” fax machine option. AKA: Beat the printer with a baseball bat (for those of you that don’t get the reference). Again, I just want it to work…

I ordered mine mid December.

I just bought the printer at xmas. It was delivered two weeks ago.
But I bought from Dynamism as part of a bundle with an einscanner… so I have no idea how long the cartridge was in their warehouse.

I was wondering if its the actual resin TYPE that the sensor can’t read. I am running the Durable resin, which is extremely viscous… and the wiper shoves a berm of it up the back wall every time it goes across, and it takes ten seconds or more for it to drain back down to level.

I know the machine only “senses” resin once in a while, not after every layer,
I assume the resins that will print to 25 microns are less viscous… are you guys having the same issue with the Grey resin or Clear?

It could also be a bad batch of Sensor components, that affected Printers built at a specific time…
unfortunately Formlabs serial number ‘names’ makes it impossible for us to compare serial numbers to see if all our problematic printers were built in the same week.

Our company got the printer about a year ago. I’m the issue with black and clear (only have two cartridges at the moment).

The cartridges have a serial number underneath. 20171004 is one of mine. I’m guessing that means manufactured on October 4th, 2017.

I’ve only been using the clear resin. I had thought that might be the issue, it being clear, but I guess I can rule that out. My machine spends hours trying to resume the print, and then just gives up. It never completes. I have three prints on my desk that are three quarters of the way finished.

My cartidges were also made in october.

I haven’t had the printer actually give up.
I have given up and pressed the abort button, resulting in an incomplete print…
But if I just leave it… it eventually resumes… but with a visible flaw layer at the pause point.

the last time it was stuck in a resin error loop for 19 hours… but it resumed printing.

the Printer’s touch screen looks hung… but the dashboard reveals every attempt to resume and every error and its time.
For every resin sensor error, the printer pauses for exactly 5 minutes, then attempts to resume printing.

It appears to keep making the attempt for as long as you do not abort.

Can I suggest that you check the temperature both when the printer is working and when you have an error?