Resin cartridge still not detected


I wrote here a month ago about my Form2 not detecting cartridges and slow response from support. I finally got the printer replaced but the problem was not totally solved since a clear cartridge was still not detected. Today I received a new clear cartridge and you can guess that it doesn’t work!

Any suggestions how to get either of them working? A black one works fine with the new printer.

Hopefully the support crew also reads this and I will get better service soon. The open ticket is #60428. This is not the only problem but definitely the one needing most attention.

All the best,


I have something to add. I know the ID thing is an IC but I still I tested with a multimeter and there’s a difference between the chips. The chip on the black cartridge gives a resistance of roughly 10 megaohms, whereas the chips on the two clear cartridges show infinite resistance. I think this must be an electrical problem.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.