Resin cartridge not detected

Hi fellow formers,

Has anyone ran into the problem of resin cartridges not being detected by Form2? By brand my Form2 is not detecting cartridges at all.

Also, how is the response time from the support nowadays? I opened a request two weeks ago, got some pretty evident things to check and replied, but then I haven’t got any reply for more than a week.

I’m getting frustrated because the printer has been sitting useless for two weeks now. I could print in open mode but I would lose most of the nice features so I will not.

Greetings from snowy Finland,


Thanks for your patience with our support team, Markus. I’ll be sure to look into the delay and see about getting you some quicker attention. If I had to guess, it sounds like one of the identification chips - on the tank or the cartridge system - is not making complete contact due to a physical lack of connection or contamination on the chip. We’ll get more details into your support conversation.

I guess the problem is on the printer side because neither of my two cartridges work. If there is contamination, it’s likely from the factory because the printer never detected a cartridge.

I have had this with just one cartridge, all the others are fine. The one I have had the problem with is intermittent, so it will recognise the cartridge and then mid print say no cartridge installed!

I assumed its a problem with chip on the cartridge but your problem sounds quite different!


I have a similar problem with a brand new Form 2 I just received. I have two cartridges and neither are detected. Markus, did you find out what your issue was?

Vladimir_s: No, the problem was not solved and the printer is being replaced. I think the chip reader or its contacts in the printer are somehow not working.

Hi Vladimir, There are a few things we can try to resolve your cartridge detection trouble. Have you had a chance to open a support ticket? We would be happy to help!

Hi Kara, I did, and Zach from support pointed me to what turned out to be the cause of my problems - there was some sort of non-conductive film / residue on the cartridge contacts. After scraping it away the cartridge was successfully recognized. I’m still working with support to troubleshoot another blocking problem related to filling the tank, but at least the cartridge is now being detected.

Thanks for your help!


I just had the ‘cartridge not detected’ problem, and it was similar to what Vladimir_S said… the contacts on the cartridge weren’t clean. I had to rub them down with some IPA then the cartridge worked.

Worth noting: There was resin in the sealed bag with the cartridge, which surprised me. Not a lot, just a few drops, but still… there was a leak in transit (which is probably how the contacts came to be dirty)

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.