Printed directly on the platform -- cannot remove print


#1

I’ve built directly on the platform, but now my prints are stuck on the platform.

I’ve tried the scraper tools, and other thin edged tools to pry it loose but no luck so far.

Any other ideas? I’ve heard potentially putting the platform in the freezer, but haven’t tried yet.

Thank you!


#2

… try hypothermia (-10 … -20 ° C should be enough).
The aluminum contracts more than the resin.
This means that large-area parts can be detached from the building board particularly well.

Hot water on the frozen conglomerate may help with the separation.

I wish you success!


#3

Placed the whole platform in the freezer for 20 minutes, and the print popped right off!

I spent a few hours last night and today trying to get it off and after placing it in the freezer, took a couple seconds and had a clean separation.

Only thing I’d advise is that the build platform stayed ice cold for a lot longer than I expected once coming out of the freezer. Seeing how the cold platform allowed for an easy removal, I waited until the platform was room temp before using it for a new print.

Thanks for the help


#4

Bit of a late response but when I have issues with removing a print I use a heat gun on a low temp and heat the part, makes it easier to pull off. :slightly_smiling_face:


#5

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.