Preform 2.10 not starting

Hi I’m having difficulty getting preform 2.10 to start I keep getting the screen below on start up.

I can get it to run by using PreForm (Software Rendering) version so its not a big deal it just seems odd that the application isn’t starting.

Any suggestions?


I am having the same issue with version 2.10.0. Here are some event viewer details from the failure. Any help would be appreciated.


Same here running latest Nvidia drivers. Anyone have a link to the last release. Running in software mode is very very painful, virtually unusable.

Is This what your after?

1 Like

When you hit crashes on Windows like this, it’s really helpful if you could run dxdiag and send us the output. That will give us things like graphics driver version numbers. For example, kystopz89’s issue looks like it could be this rather infamous Intel bug, but I can’t really be sure without knowing the driver’s version number.


Here is my dxdiag output. I haven’t had any issues with previous versions of PreForm, just the latest 2.10 install.

Hi sorry about that. here it is likewise though the previous version worked fine for me.

DxDiag.pdf (89.9 KB)

Thank you to everyone who has sent me dxdiag output. It does appear that a change we made to the OpenGL shaders in PreForm 2.10 tickled the bug in Intel’s GLSL compiler that I linked to above. It appears that this bug existed in their drivers from version 4139 (released ~April 2015) through 4264 (release 8/19/2015). If you are having problems with 2.10 and you have Intel graphics with a driver in this range, you should probably try upgrading to new drivers and see if their fix works. If you’re encountering problems with 2.10 with a driver version outside this range, please let me know about it.

I also have 1 or 2 reports about problems with PreForm 2.10 on nVidia cards, but I’m afraid I don’t have enough information to act on. If you’re seeing problems with 2.10 on an nVidia (or on an AMD), it would be really helpful if you could send me more details.


Thanks for the help! No nvidia issue anymore here, I just have one of those dumb laptops that will run programs either using the Nvidia GPU or the built in Intel graphics. When I manually set the program to run the Nvidia GPU it works fine, when running off Intel it crashes, exactly as you described. Works fine for me now!


Ah, that makes sense! Thanks.

I updated the drivers yesterday but that didn’t work, however today I got the notification of 2.10.1 and that works nicely!


The updated Intel drivers (or switching to the Nvidia GPU) worked for me. Thanks for the help!


We released an updated version of PreForm this week that has a workaround for this Intel driver issue. It’s version 2.10.1, and you can find it at the usual place. Tell me if you have any more problems with this version.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.