3.31.1 update

After updateing to 3.31.1, I can not launch PreForm.

Ive uninstalled, restarted, installed, and still no luck. It had been running just fine, untill i updated.

Is it me? Thank you.

windows 10
form 3+

Hi @SGuerra71,

Thank you for getting in touch. I’m sorry to hear about the PreForm issue you encountered. One quick test you could try would be to run the “Software Rendering” version of PreForm found in the installation directory. Whether or not this helps, I would encourage you to get in touch with Support, and they’ll be able to take a closer look and get logs from PreForm if needed.

Thank you. After much troubleshooting, I was able to download 3.31.1 to another computer without issue, so my problem is the computer.

But I can’t seem to figure out why it’s not launching on my original computer. The windows 10 error I’m getting is “the application was unable to start correctly (00xc000007b)”

I obviously googled that, and tried a few different suggestions…but still can not get it to launch.

If there’s any IT peeps out there, I’m open to suggestions.

Hi @SGuerra71,

Thank you for clarifying the error message. I was actually able to find some more info on this. Please download the latest Visual Studio 2015, 2017, 2019, and 2022 versions for X64 architecture: Microsoft Visual C++ Redistributable latest supported downloads. Let me know if this resolves the issue.


Thank you so much for that info, that solution got me up and running.

You don’t know how many things I tried, I was about to get a whole new computer.

…now I can get back to work.

No problem! I’m glad that did the trick. There is a new dependency that PreForm has for this C++ runtime library. Most computers already had it set up, and few users were affected, but otherwise it would have to be installed manually.