What is wrong with Preform?


#1

Lately i am not able to get Perform to work correctly, unless i run it as administrator.
it seems that is has something to do with Windows 10, maybe an update or something like that? All versions since 3.5.2 arn’t able to open a new object, without crashing in the OPEN dialogbox.
Anybody have a solution for that?


#2

Just to say that I have the same problem has you.


#3

yea same here, I did ask support if they have noticed any issues with it but no response yet.


#4

Still the same in version 3.8.1. but it can be overcome by running Perform with administration rights. :face_with_raised_eyebrow:


#5

There are a lot of different "Windows 10"s. PreForm is working fine on my Win10, which is Win10 Pro version 2004 OS build 19041.450. Which is about as up-to-date as you can get without using Beta release stuff. If you haven’t already, check your Win10 install and make sure it’s up to date…


#6

Pre-form has been broken since the release with adaptive layering. You build your model and save it. Close it and then reopen to go send to printer. The supports now say the model is unsupported. You go into the model and edit supports and apply. You go from having mini-rafts or none to having full rafts …even though that is not selected. You call up recent files and you get the same problem. It’s driving me nuts! It’s unworkable. :frowning:


#7

Do you have 3D connexion installed on your computer?


#8

No i don’t have a 3D Connexion installed.
There are nothing special about the setup of my computer.
Windows 10 Pro with the latest updates, Office 365 etc.


#9

I totally agreed that the problem started after the upgrade of the software. I can only run it on my main display on my computer if I move the application to my other display; the software does not do anything. So far, the software is the problem. I had to download and install the software three times.
version 3.8.1


#10

This is the error i get i the Event Viewer when i try to load a new object.

Faulting application name: PreForm.exe, version: 0.0.0.0, time stamp: 0x5f5a8bb7
Faulting module name: Qt5Core.dll, version: 5.12.6.0, time stamp: 0x5dc59681
Exception code: 0xc0000409
Fault offset: 0x0000000000028828
Faulting process ID: 0x23f8
Faulting application start time: 0x01d68d1556c72be9
Faulting application path: C:\Program Files (x86)\Formlabs\PreForm\PreForm.exe
Faulting module path: C:\Program Files (x86)\Formlabs\PreForm\Qt5Core.dll
Report ID: 09d9fc4d-1138-45e3-a569-a07c9d823e8c
_Faulting package full name: _
_Faulting package-relative application ID: _

_Bad service type in ._formlabs_formule.tcp.local. Application protocol name must be underscore plus 1-15 characters. See http://www.dns-sd.org/ServiceTypes.html


#11

Are you by chance attempting to access files across a network vs. local?


#12

No. all files are local.
ok this is strange. When i try to open a local object from the desktop, without network connection the preform dialog box stays open for longer, before closing preform.


#13

Disable your network interface card and see if that makes a difference. You won’t be able to print anything, of course, but if it doesn’t fail when you open an object, it’ll help figure out what to try next.


#14

Disabling the network interface did not do anything helpful
neither did reinstalling the network drivers.
Even tried to remove all network adapters.


#15

Well, looking at the error it sure looks like a network issue. But beyond that I got nothin’. Sorry.


#16

all versions up to version 3.3.0 works flawless?