Mixer check failure

In searching around…I just started getting this also. The wiper arm comes loose in the front only when the Build tray comes down for the last arm swipe before it starts. So the build tray is as close as it can get then the arm goes across for the last time before the build starts and you can see stuttering across THEN breaks free and the build comes up with the error. I have been ignoring after retrying 2-3 times. This just started on my last 2 buiilds BUT I had one in between where it didn’t happen so its very odd. I assume the magnet of the front side is having problems like your video shows. Sucks cause I am using my own machine because work has been closed up and we are all working from home. Was there a final verdict on the above problem when you had it? Replace magnets?

Hi, I have same problem.

We found and fixed one issue yesterday: The pin that hold the magents has worked its way lose and has been catching on the housing - presumably stopping the front set of magnets from rising up full, but only sometimes, see pictures and the groove it caused.

I took the LPU out and glued the pin in with epoxy resin.

LPU removal:

Printer on, maintenance menu , LPU replacement option, follow step and switch printer off.
Undo the 4 hex bolds on the dark plastic cover on the right side of the LPU head,
Carefully unplug everything left and right but not the central ribbon.
On the left hand side of the LPU head undo the 3 bolds near the hand screw knob, and undo this knob all the way then screw it back in 3 turns. Use the knob to push the LPU out of its case, there is a foam seal that makes it difficult.
Put the LPU head out the way and cover it so dust doesn’t get in.
I then undid the motor for the magnets, the top screw needs a round hex key a gear is in the way, but it can just about be done.
This allow the magnet assembly to move and the pin to bonded in, it not easy!

I was worried about the dust the pin chaffing had caused but no need as the LPU is separetly sealed inside the case, just dont blow any dust down into the LPU if you take the top cover off, wait until the LPU is out the way.

Problem is I fired it up, it auto calibrated the LPU, the levelled it, left it 24hrs to set really well… Any we get the same mixer failure where the wiper detached at the front, and a lot of swearing.

I cannot belive that the pin was at least not one of the issues with the wiper detaching - maybe I got glue somewhere I shouldn’t but I was very careful to clean all the excess and make sure it moved ok before it was reassembled.

The other causes we previously looked at were magnet strength - we happen to have a gauss meter and they measured the same front and back - so its not that. The other was temperature, so we put a heater in the room to keep it a cosy 20 degress C 24/7. - So it cannot be that either. I checked the tank position and that ok too. Oh - and absolutely no debris anywhere to stop the wiper movement.

So not quite sure what to do now as the first print in tough2000 has the wiper detaching several times allready, it seems to be just about picking it back up again so maybe we might be lucky but its not good as it should not detach this easily!

Formlabs haven’t really helped yet, they have asked several times via email ping pong for photos /videos which I had already given and keep giving and they seem to ignore what I actually wrote too and just return a vague so sorry were here to help, if you can supply some video and photos… I’m not quite sure what more information and examination I could be doing - how many other people happen to have provided gauss meter readings, videos of the failure, mechanical inspection and photos. Really - a phone call would be much faster and cheaper for everyone.


Were you ever able to get this issue resolved? i am also running tough 2000 and after 20 prints, my mixer is detaching! I cleaned everything really well, calibration, etc…nothing. Always breaks free on the FRONT side of the mixer when returning home (moving left).

Submited a ticket, but havnt heard anything back yet. Lost a lot of resin troubeshooting this so far…

Thought I would post an update on my specific case:
I contacted service, and they ended up sending me a brand new tank. I filled it up and the mixer decoupled right away. But i tried the print again and everything was fine for a few prints. I would actually notice the mixer decouple but then get picked back up, no worries.
Then yesterday, the mixer decoupled mid print and the build platform collided with the mixer but continued trying to print, resulting in a layer bonded to the film in the build tank.
I updated Service, still waiting to hear back. This is super frustrating.

Formlabs support had me take apart the LPU and inspect the magnet/mixer coupler mechanism to verify it was not stuck. (There is a pin that apparently is known to get loose and cause problems, as mentioned earlier in this thread by a different user).
There were no issues with my mixer coupler system, and the pin was fully secure so Formlabs is sending me a new printer under warranty.

I am currently having the same issue with my Rigid 10K tank with a Form3+ and Form 3 Bed V2.1 (just started printing with this resin for the first time with Rigid 10K, so new tank and new cartridge). It is always the front side that fails, and it fails while it’s on the final return sweep (from right to left) while the resin is flowing over it.

I have never experienced this decoupling while printing with Tough 2K or High Temp V2, so it seems like either this specific bed/mixer or the density of the Rigid 10K (seems significantly more viscous and seems to have a higher density) is causing the decoupling.

If I may ask, is there an online guide published by FormLabs for checking that specific pin on the LPU, or was it just text instructions via email?

1 Like

Interesting, is Rigid 10K more viscous than Tough2000?

I didnt find any issue with the magnet pin, and am finding it hard to believe there is actually anything wrong with the printer…but I’m assuming they know something that I dont. (maybe the mixer motor starts to fail?). So we’ll see.

I send you the guide in a message. I am pretty sure that if you go through the guide without contacting support first, it could violate your warranty terms.

1 Like

I contacted support over the weekend and they will be sending a new printer since our lab’s printer is still under warranty. Thank you for the guide, it will be useful information if we ever need to troubleshoot after the warranty expires!

I do wish there were an easier fix though, since it seems like a relatively small issue with the magnets or gears/motors. Maybe an upgrade to the mixer arms (stronger magnets for the three in the front, since that seems to be the only side that fails) would resolve it in the future.

1 Like

It seems like a very strange issue. I don’t really understand what could possibly be causing the issue, since the mechanism is so simple, and when inspecting mine, it seemed fine.

I just received my (new) printer today, and it appears to be printing fine (so far). I was hoping that maybe FL fixed something and isnt telling us, but I don’t have high hopes. The new printer arrived with firmware version 1.13 installed, which is from July of last year. (current firmware is up to 1.19.7!!!)

1 Like

I am also worried about the new unit we will be receiving-- since there isn’t a specific solution I really worry about this issue popping up again since now that I think about it, it must actually be extremely expensive or difficult to fix.

Their engineers must have determined that it would be financially infeasible to fix/prevent this issue. The common resolution seems to be an RMA which is pretty expensive for FL (shipping and handling of such a large, heavy object both to and from the end-user) and the risk to customer relations, or the product reputation regarding reliability. The cost of preventing/repairing this issue must outweigh all of that.

I haven’t heard of any on-site repair techs being dispatched for this issue, so if a trained and certified tech with specialized tools can’t repair it, it must not be something repairable within reason by a customer either.

Tech support has been extremely responsive and helpful, but I am worried about the Form 3 as a whole since this seems to be a recurring issue with this generation, and does not have any clear path to resolution besides replacement.

1 Like

Not always a mechanical issue. I started a print the other day, actually ran maybe 100 layers before I got a mixer arm error. Straightened it out and did a retry, came loose again (front edge). Did a few “lather rinse repeat” cycles. It always came loose in the same spot. The next retry I did, I reached in with my finger and “helped” the arm move. When it got to the spot where it was having problems, it carried through but I could feel it had snagged on something. So I’d had a print failure and resin was stuck to the film on the bottom of the tray. No way you’d know that if I’d just canceled the print and removed the build plate because the print would be incomplete anyway. And if I didn’t go looking for resin stuck to the bottom of the tank, I might think something in the printer’s mechanics was defective on every subsequent print I attempted… I changed to a new resin tank and the problem went away. If you change the tank and the problem persists, it’s something in the printer’s mechanics.

In addition, my printer is a basement workshop. It’s only about 60ºF ambient. Takes forever for the printer to warm up the resin for a print job. Usually, I have to crank up the heat (the vent directed at the printer) to even get to the target printing temp. When it does finally start, sometimes the resin in the center of the tank is still too viscous and I lose the wiper arm every time it sweeps unless I let it “stew” a bit more (because I’ve “cheated” the printer’s heater by supplying it with warmer air).

1 Like

Definitely strange. I work in an industry where we sometimes have issues with a product, and eventually identify a fix, and like FL, we certainly don’t tell the customer that there was an issue OR a fix. We just send them a new product when they call.

So I get it, but its such a simple mechanism that I cant figure out what they might have fixed (if they did). My alternative speculative guess is that it could be the little DC motor gearbox that actuates the magnets. Those motors are made super cheap, and they may have simply identified that they fail unpredictably after a while and until they find a more reliable unit, its best to just swap in a new one. Only FL knows the answer.

Unfortunately the mixer decouples with all three of our resin tanks, one of which has never been printed on (just filled to aid in lubricating the tank surface).

Our lab usually sits at around 65-68ºF, and we noticed a long heat-up time as well but were also weary about potentially overheating the printer so we haven’t tried directing a low-powered heater at it. The Form 3+ suitable ambient temperature range is 64–82 °F according to the manual, but it does seem like being near the lower limit may cause issues with the resin viscosity.

Supplying the printer with warmer air still doesn’t result in even heating for your printer? Would an enclosure help keep things more even?

I am going to ask support before attempting a temperature controlled enclosure (like those built for filament printers) since I could see a test like that voiding the warranty.

Unfortunately it seems like they haven’t been able to identify a fix yet since the first videos of this issue I’ve found on YouTube are from 2019 with the original Form 3. Our unit is a Form 3+ and seems to detach in the same manner (front first), and also has the stutter shown in other videos.

1 Like

yeah, I suspect its a known issue that affects x% of printers with no clear fix.

1 Like

I am also having Mixer failures with a brand new Printer: 3BL
Printing Elastic 50A for a 30 hour print and it has failed 3 times now. Correctable by manual intervention and can continue the print. Unfortunately we are on a tight timeline. Problem for us appears inadequate support up to the build platform and the model too heavy and delaminating from the build platform.

Ah, if your model is separating from the build platform and causing the mixer to detach, (throwing a mixer check error) than the mixer itself is actually working as designed. The mixer serves two purposes, mixing, and checking for failed prints.
If a print fails, it could damage the resin tank and/or printer.
If you are having a lot of issues keeping the model stuck to the build platform, I would suggest contacting support. they might have a solution for you. (also check for latest firmware)

1 Like

UPDATE: Mixer just decoupled on my 3rd print with the replacement 3+. Its stuck under the build platform, and the printer is continuing to print…because why not? Still using Tough2000.
Ordered some 1500, hopefully it prints more reliably…

1 Like

Keep us posted…

1 Like

Hi @nauticalknowhow,

I just wanted to reach out and let you know that your best bet would be to open a Support Ticket if you are still having any issues with the mixer.