Mixer Check Failure, tried other fixes

So I have read through all topics I could find on this and couldn’t seem to find a solution for my issues.

Printer was working fine, last used 2 weeks back, been in sleep mode since and under a cover. Turned it on yesterday to print and there was a very loud “clicking noise” when attempting to move the wiper which went on for 10 seconds or so as it tried to do it thing followed by “Mixer Check Failure”

So I tried to re calibrate the resin tank sensor and after it does its thing it brings the arm to the middle of the tank fine.

I then will try to do a print after it has rebooted and again it wont work. This time the resin tank almost “jumps” but in the same place.

I have tried with 2 seperate resin tanks and both are doing the same. I have swept the motors left and right and there doesnt seem to be an issue there. I have been told it could mean the main screw needs greasing (so I have ordered this to arrive tomorrow) but wanted to see if anyone else has any idea what it could be. It doesnt feel like the fix would be as simple as greasing anything however I may be wrong…

Thanks for any support/advice


Good morning @CMWToys -

Thank you for reaching out about your mixer. Lubricating the lead screw is a possible solution if the x-stage is hitching, but if you have video of the noise and mixer behavior, sending it to Support would be great so our Services team can help figure out what’s happening.

Kind regards,

The arm is moving better than it was after adding the grease however still clicking when trying to make the resin arm go all the way to the left when trying to fill.

Will email what I can to support.