Form 3 mixer arm gets stuck halfway (with loud noise)

A Form 3 started doing a strange thing since a couple of days ago (has been working perfectly for almost one year now). During the preparation phase, the mixer arm gets stuck halfway when sliding across the resin tank. It does not get lose because of a dirty tank, it just stops abruptly at about the middle of the tank (the LPU movement also stops there).
When stopping it does a very loud noise. I then abort the print and LPU goes back to its initial position without problems.
I bought a new tank, because I thought the problem would be the tank, but it does the same thing with the brand new tank.

I have uploaded a 43seconds video that shows the moment the mixer gest stuck, and the strong noise that can be heard

Does anyone know which might be the cause of the problem?
Thank you.

I’ve seen this happening. The cure was to apply grease to the ‘x’ lead screw.


Agree with billb. Try white lithium grease.


Thank you very much for the tip.

I have a couple of pillow packs of Magnalube-G
Would this be recommended to grease the Form 3 lead screw? Or should I buy a different grease?

1 Like

I have had this problem today. Thanks to your guys discussion I succesfully put some lithium greas on the x lead screw. Problem solved!

Same here, I applied grease and it worked. Problem solved since.

Hi. Where is the lead screw? This has happened to me as well. Thank you!

Hi @Carmit,

I know this is a very late reply, but the lead screw is the large metal screw that runs horizontally in the printer.