Interlock error on an older form 1


I bought a used Form1 that worked great for a few prints, but started showing an interlock error for no reason as soon as a print job is sent. The hall sensor for the lid and the z axis micro switch both work properly. I have seen the other thread where it was mentioned that a reinstall of preform fixed the problem for some people, but it doesn’t in my case. I have even tried it with a second computer (one windows, the other a mac). The only workaround I’ve been able to find is reverting to preforms 1.7.x, which really isn’t any kind of solution. All of the 1.8.x versions fail.

I noticed that nobody from form labs bothered to comment on the other thread that mentioned this issue, so perhaps they’ll jump in this time to let us know what is going on and when this major defect will be resolved. I know that I won’t be ordering any more supplies from them until I find a solution. If I run out of resin and SLA print jobs need to be done, I guess I’ll have to look at buying another SLA machine and writing off the Form1 as an expensive failed experiment. That would really be a shame because the prints I have made so far turned out great.

I’m sorry to hear that you’re having trouble with your printer. The interlocks are located at the interface where the printer’s cover meets the metal base – can you post a picture of this area so we can see if there’s anything obviously wrong?

You can also open a ticket and get help from our fantastic support team.



Thanks for jumping in. I’m out of town for work at the moment, but I can tell you that the sensor is functioning properly, as it triggers when the lid is opened and closed. Nothing has really changed there. The problem doesn’t exist with preform 1.7, but as soon as I update to 1.8, I get the interlock error as soon as a print is sent to the machine.

I didn’t contact support because I am the second owner of this machine and it was already out of support when I bought it, hence the reason I brought it up here in the forums. I don’t expect direct one on one support for a machine I didn’t purchase directly or that is past the warranty period. Since this same error had already been mentioned here, it doesn’t appear to be something specific to my printer, so I think the problem would best be addressed publicly in case others have run into it.

I’m hoping its something as simple as an upcoming preform or firmware update, but some kind of roadmap for that sort of thing sure would be nice. I know this isn’t the first time this issue has come up and the software/.firmware folks at Form Labs could certainly explain the conditions under which that exact interlock error message would be triggered, as they wrote the firmware that generates it. If the machine is operating and I open the lid, it pauses as expected and resumes when closed. If it isn’t operating and I open the lid, it tells me the lid is open and asks that it be closed. What is it about sending a job from preform 1.8 to the printer that could possibly trigger an interlock error when the interlock state hasn’t changed? A bug is the only thing that comes to mind. Considering that it worked fine with preform 1.8 for the first few prints and now it only works with an older version of the software is mighty suspicious.

I can post a photo whenever I get back to home base in a few days. Is there something specific that you’re looking for me to capture? There isn’t much to see. The lid sits flat and is aligned such that the sensor registers opening and closing events just fine.

I’m having this same issue. Has their been any fix?

Not yet. Call me stubborn, but since several of us are having the same issue, I’m asking that Form Labs address is publicly so we all know what is going on. It seems that every issue that comes up with these printers turns into a one on one support ticket and then disappears. I’ve been asked to provide a photo of the interface location as well as the name of the printer. I’m not at home to take a photo right this second, but RitzyAnteater isn’t a happy mammal with 1.8.X.

Matt, this issue isn’t specific to my unit and it isn’t a hardware issue, so 'll put the request out there again… Form Labs wrote the code, so the reasons that error would come up are no mystery. Since the interlock is working fine for printing and in other versions of the software, it stands to reason that Form Labs has changed something related to the printer status messaging in 1.8. The fact that it persists between machines also implies that it might have improperly written something to the controller firmware or eeprom in the printer.

I’m sure we all understand that software development encounters bugs. As long as those defects are acknowledged / explained and some commitment is made to resolve it in a timely fashion, its just the less pleasant part of the normal software development cycle.

Andrew, have you tried reinstalling the software? Tried it with a different computer? I’m curious if the problem follows the printer for you as well.

I Uninstalled the software and reinstalled. I looked around Google looking for a fix. Even installing a magnet straight to the sensor. And I’m sure the z axis is functioning correctly. The thought to check it was while the printer was off, wind the platform down an inch or so, then boot up. Z axis moves up and stops at the sensor. I did notice one or two of the wires of the door senor are a littttllllee pinched… but not enough in my mind to cut and resplice. I will try a new computer here tonight and post my results.

Well, to no success did the new computer do. This issue happened right after doing a test print that failed (print stuck to tray), cancled the print and went to level the tray. All was well until then.

Ok. I am now able to confirm it is a software issue. My printer came with a cd with preform. Installed it, and no more interlock issues.

I guess add your critter’s name to the list of victims. What version of preform came with your printer? Mine will run with anything up to 1.7.X.

As Matt mentioned above, the best way to find the source of the problem and resolve the interlock error will be through our support team. I’ve just followed up on your email message, Andrew; thank you for getting in touch so quickly. David - if you’re also able to reply to our email with your printer’s serial name (from the back panel) this would greatly assist us.

Formlabs does not ship printers with a CD installation of PreForm, and if this is the case, perhaps both of these printers were purchased second hand? Please know we’re here to assist no matter who purchased your printer. You can always download the latest PreForm software and firmware versions directly from Formlabs’ site.

Stephen. I mentioned in my original post that mine was purchased used. I didn’t get a CD, so I just installed the latest version of the software from the website and was good to go for a while. Eventually, the interlock issue cropped up and after looking here, I found the thread that mentioned dropping back to an earlier version of the software. After some trial and error, I found that the 1.8 upgrade was the point that things break.

As for the serial, I also posted it earlier in this thread. RitzyAnteater is the name of the unit.

Thanks so much, David, and sorry for overlooking your mention of the serial name. I’ve gone ahead and re-opened your ticket. We’ll get back to you by email to help resolve this.

I’m having the same issue - was this ever resolved? Also happened after a failed print running the 1.8.2 software. Seems like a software bug as my Z switch and lid interlock are also working just like David_Persuhn mentioned

Chris, are you running a CTC printer by chance?

You’re a good guesser :wink: Judging by the release notes (very short on this latest revision) I’d guess they blocked alternate printer vendors from using their software in 1.8.2 (or earlier?) I have all prior versions of the software so I’ll take a look at it tomorrow and see when it stops working.

For anyone else wondering, the Preform software currently runs up to 1.7.1 ( on a third party SLA printer, anything version 1.8 or afterwards will show an “interlock” error on a non-Form1 printer.

1 Like

where did you download 1.7.1 from? link

E-mail my first name at my full name dot org

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.