Form2 frozen during printing and don't let me to reboot it


#1

My Form2 machine is frozen. It says that printing is going on, even it’s stopped during the first layer. It does not allow me to put that printing in to a trashcan or do reboot. I can’t stop the printing and start next one because reboot from the setting menu are not available during the printing. I have already try to reboot the machine by pressing start/stop button more than 30 seconds and keeping the machine without electricity more than 10 hours. What should I do?


#2

Try to do a factory reset:

Unplug the printer, wait 10 seconds, then connect power again.

Directly press and hold the button at the front until it shows you a message that it is resetting the printer.


#3

I would start with just an unplug and replug to power-cycle the machine, only because the full factory reset might be overkill for this particular issue.

If that still doesn’t work, please reach out to our support team here, and they’d be happy to lend a hand! :slight_smile:


#4

I think he already tried that:
10 hours power-less sounds like a long time.


#5

Oh gotcha! Thanks! I’d still get in touch with support before messing with full factory resets, but that’s likely the next step.


#6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.