Frozen During Power On


#1

I put the Form 2 to sleep before leaving work on Friday. When I came in this morning, I couldn’t get the printer to wake up. I unplugged it and plugged it back in and it turned on fine, but the touchscreen wasn’t working. This happens to me fairly often, and I normally resolve it by unplugging the printer and plugging it back in, since that is the only solution I’ve been able to find in the forums. So I tried doing that, and this time the printer froze during power up. The progress bar does not move at all. I’ve tried unplugging it and plugging it back in several more times, and every time it turns on to this screen and doesn’t change. Has anyone found a solution to this issue? I will also open a support ticket, but I suspect Formlabs will want me to send the printer back for repair, which I’d rather avoid.85f50b6c91a1cea63ebe883ea5567a44a1d1738a_1_491x500


#2

For anyone else who has this problem in the future, here is what I went through with the support team:
They had me try a factory reset. The printer wouldn’t do it. I was supposed to reinstall the printer’s firmware after the reset, but I obviously didn’t get that far.
Checked both ends of the ribbon cable connecting the touchscreen to the motherboard to make sure it hadn’t come loose. Also checked for any resin inside the printer that could be causing an issue. Did not see any issues.
They then asked for a video of the printer trying to boot up.
At this point, I was given the option of replacing my Form 2 ($1299) or selling it back for a $700 credit toward the Form 3. Going through with the replacement.