New Printer Touchscreen will not function

After unboxing our new printer hooking up all the cables and turning it on for the first time, we notices the touchscreen will come on but will not navigate to any of the menus. I have done a factory reboot, I have tried to load new firmware but I need to press the screen to continue. Any help would be wonderful. I have put in a request ticket with the help desk but have not heard back yet.

Forgot to add that it is a Form 2 Printer.


I had this issue in the past. Disconnect the printer from the wall and wait a few seconds, then plug in the wall again.
This solved the issue in my case.


Let me know if @ClaudioPin’s suggestion corrects this. If not, I’ll make sure to get you in touch with a member of our support team so that we can help troubleshoot with you.

1 Like

Had the same problem with the new Form Cure. Unplugging and re-plugging cleared it up.

I had the same issue with the unit I received in early December. FormLabs had to ship me a new unit after several attempts with tech support to fix the problem. Tried rebooting, updating the firmware from Prefoam with a wired connection, and they even had me open the unit to see if the ribbon cable had loosened. Nothing worked. They shipped me a new unit. The screen is working on the new unit but after test print the laser has seemed to have stopped firing on this unit. Ugh.

I am currently having the same issue. We previously had 2 machines that suffered frozen screens that would clear up with a reboot, but our latest printer was frozen right out of the box, and will not register touches. Tried rebooting, factory resets, and checking cable connections, but nothing has resolved the issue. Awaiting a support response now.

@szemke @peelio Did the machine show up in PreForm despite the frozen screen? I have battled network connectivity issues on the last 2 Form2 machines I have received. Wondering if this machine will have the same issues.

It’s really embarrassing if the machine don’t work when needed.

The machine would show up in Preform. After working with tech support we have discovered it is a bad screen. They are sending a new screen out.

1 Like

@szemke Interesting. Unfortunately that means I am likely experiencing ongoing connectivity issues. If I discover anything useful I will be sure to pass it along on the forum.

You would think they would fully test their product before it leaves the factory. They obviously are not sucessfull at this! Whos going to spend 10k and worry if their new Fuse is fullu functional?

Same issue. I’ve to reboot and then get it to work. Still struggling with firmware update and Decryption not supported issue

@AkashPai I had the decryption error a few months ago on a replacement unit. Formlabs was able to send me the firmware update directly and I was able to manually upload it over USB. Not ideal, but only had to do it once.

I had these same issues with my new Form2.

  1. Firmware failed on decryption.
    Solution: Reboot AND disconnect power to the printer, re-downloaded firmware update - Update succeeded.
  2. Touchscreen was frozen after the reboot of the firmware update.
    Solution: Reboot AND disconnect power to the unit.
    Touchscreen has worked fine for 2 weeks now. It’s very likely a minor issue with the factory final test and the firmware update not doing a live-restart to clear the touchscreen memory.

My touchscreen freezes randomly after prints.
I have made all the firmware updates, and each time I still noticed this.
The workaround is simple (put to sleep and re-activate), but for a machine of this price, I find it un-acceptable.

1 Like

I have same issue with my Form 2 touchscreen it’s also freezing after finish printing, tried upgrade firmware (which is affect the printing quality!) and downgrade it again with same issue, Formlabs have to consider that issues seriously!

1 Like

Just wanted to add I had this issue as well- the top half of my touchscreen wouldn’t work on a brand new unit, never even got to try to see if it would print. Had to take it apart and reset the ribbon cable and it didn’t change anything. I ended up having to get a replacement unit.

1 Like

Brand new unit less than a month old and was working perfect till the firmware update yesterday.
This crap is unacceptable. I guess I have to take to FB and other social media platforms to get them to get this crap fixed.

We pay close attention to the forums as well, and I read through each of the new threads daily and report issues like these to the relevant teams. Your reports are a big help in allowing us to identify how prevalent issues like these are in the field so that we can work towards solutions. Are you still running into touch screen issues @orthostar? Our support team is happy to troubleshoot this with you, and I can get you in touch with a member of our team.

Hi @Frew. I’m also having the same issue. Prints are fine but a frozen touch panel, not screen, Since pressing the power/sleep button still works.