Form Cure, what thermistor does it use?

My Form Cure won’t heat anymore, it just goes straight to curing, zero re-heating and even after an hour of running the camber is just above ambient.

This morning I took it apart to see if there was anything obvious, I was suspecting the thermistor to be broken as it seams to think it’s already up to temperature when it starts.

Taking it apart was no problems, everything was pretty tidy, all leds on circuit board and the thermistor completely separat., though no markings as it’s casted into a ring terminal.
I measured it to about 12k ohm at around 22c decreasing to 11k after holding it for a bit.

Tried to look up 12k ohm thermistors and found what appeared to be a very similar unit, but I didn’t find any resistance/temp table to check it against.

As seen in a picture one wire was squished in two places, not sure if that would affect too much but the unit has worked for more than a year before it failed.

I’ve already been in contact with support that have confirmed there is no support or spare parts, I have to purchase a new unit at full price.

Could someone (maybe for Formlabs) confirm if my sensor reading are correct or if the thermistor seams broken?

when you first start the cycle, does in show any temperature readings on the screen?
Maybe 12k is already too low so it thinks it’s at or above temp. Since it went to 11k when you touched it, you may can try something greated in kΩ for testing. (In case 12k corresponds to 60oC+)

Or maybe try to cool it down to raise the kΩ

I’m sure the support knows the temp graphs needed, not publicly sharing is another thing…

No temp reading when it start, not even for a fraction of a second. It immediately starts the count down.

Yeah I hope someone from support will answer here and let me know if the readings are way off and in that case what type of thermistor I can replace it with.

Hi @Reine,

Thanks for reaching out about this - I’m sorry to hear about the heating issue you encountered with your Form Cure. In terms of troubleshooting, this is out of scope for what we’d be able to offer. As you mentioned from your discussion with Support, we do not have replacements available for the internal electronics of the Cure, and we don’t have the information you’re seeking about the thermistor offhand. I recognize that this may not be ideal, and I appreciate your understanding in the matter.

Did you try by lowering the temperature? Like toutching an icecube or such

No I didn’t, I saw that it reacted but couldn’t find any temp/ohm scale so had no way of verifying anything so didn’t do any more tests.

I had a look at mine, it’s 12,33kΩ at 20.5oC
And the heater is 7,6Ω

1 Like

I really appreciate that! Given you confirmed my ambient reading it would almost seam unlikely my thermistor is broken.
That for sure made this more difficult, if not impossible to resolve with my electronics experience.

1 Like

Try the updater in case your firmware is old and corrupted.
Also measure your heater in case it’s bad (maybe software sees that resistor is not good and bypasses the heating)

I’ve done the firmware per instructions from support to fully re-flash it, that din’t help. I’ll measure the heater too. Thanks

Wow what a SHAME that Formlabs wont take responsability for a clear fault at factory level and that they presumably have NO IDEA of the replacement part required… XXIst century! WOW. JUST WOW.

1 Like

Hi all,

I just wanted to follow up here and briefly add on to my previous reply. In terms of troubleshooting specifically for electrical components, it can be difficult for us to diagnose issues properly, especially through remote troubleshooting. For this reason, we shift to device replacement rather than troubleshooting for electrical issues. Thanks again for your understanding with this.

I understand that @Jesse_K and I also understand that my units was out of warranty with a few months when it happened so I wasn’t expecting much help from the support. But as already pointed out this is clearly not a user induced problem, but a hardware fault so it would have been nice if Formlabs would at least have offered a discount code for a new unit.

Though I still think it’s so wasteful to throw away a mostly functional machine because of a minor electronic issue that most likely can be resolved by changing a component or the main pcb.

Anyhow, @agiorgitis I took some more measurements to compare with your and they seam to match up pretty well. Right now I have the unit sitting out in clod storage (10c) and will get a reading from there too.

But for now, here are todays readings from the thermistor, heater and heating fan.

Heating fan


Thermistor at 20c

1 Like

Is it possible that you have set the temp setting too low on the screen?
What if you play around with the settings and the materials from the list?

I’ve tried a few different materials, I’ll test more when I have it back together.

I just took a new reading, 11c reads 16.2kOhm

Here is how it behaves. No different from previous. I found a “reset” button on the pcb which I hit while it was powered on and it clearly rebooted, but that didn’t help either.

Hmmm strange…
If you try to set the temperature all the way up (80) or down (35) without selecting material?
Also the fan is supposed to be ‘on’ during heatup and curing, is yours spinning?

Some fan is for sure spinning, couldn’t that be heard in the video?

I can hear something but not sure whether it’s the fan or the turn table.

Another idea is to check your PCB, both front and back, in case there is a short-circuit (from flux or something else) or a destroyed copper path (caused from overcurrent)

It’s for sure a fan running, I’ll verify which one later today.

I’ve looked over the pcb twice, once with my iPhone in macro mode but nothing stod out, everything looks ok. But I’m not an electrical engineer so I might have missed something.
Well I’ve obviously missed something as it’s still not working.