Form 2 + PreForm 3.6.1 = Hangs after selecting job to start

A strange issue started recently, after updating PreForm to 3.6.0 (then to 3.6.1 hoping it was just a glitch). The printer just … I dunno how to describe it. It just hangs? Take a look in the video here. Forgive my mild attempt at illusion amusement at the end.

It just gets stuck there, just after hitting “print now” at the very first, “ready to print” screen. It doesn’t even think to start the printer.

This definitely seems job-specific, as the printer had previous jobs and they would still print when requested. I tried fixing it by using “delete all jobs” in the settings menu, but that didn’t help.

Any ideas?

edit: Just tried on another computer (my personal one, virtually never used with this machine), which has PreForm 3.0.1… and it’s still the same thing. Generates print files, sends it, it appears on the screen, I hit “print now”… and it just hangs. Hmm.

update: Contacted support via chat, doesn’t seem to be a known issue, made a support ticket. I’ll follow up with the resolve :slight_smile:

I am getting the exact same issue.

Solved! Rolled back to firmware 1.9.16 (May 2020).

Here’s the support reply that got me back printing again:

Our Software Team has recently released an update to the Form 2 firmware – we suspect that this recent update may have included some unexpected bugs and are actively working to fix them.

To remedy this issue while we work on a firmware patch, I’d like to have you manually update your printer to the second most recent firmware version, 1.19.16 (released on May 21, 2020.)

You can do so by visiting this link and selecting Form 2 from the menu on the left. Then, follow the instructions in this guide to manually upload version 1.19.16 to your printer. Once you do so, please try to run a print and let us know how it goes.

Big thanks to FL support for this tip :slight_smile: Usually it’s a good thing to update firmware as soon as it’s out (for preventative reasons, e.g. to do something differently that they later found would cause premature wear), but here it seems a bug snuck in there. I’ll update again when a new version comes out, knowing I can go back to this version to fix the issue if it arises again.