Printer lock-up during first print on firmware 1.19.18

I started a print last night in Tough 2000 on my Form2 right after updating to firmware 1.19.18, and the printer locked-up on layer 61.

The print was actually a re-print of a part from the printer memory that was sent to the printer using the prior version of PreForm (3.6.0) and successfully printed once on the prior firmware (1.19.16).

This is the first time my Form2 has ever locked up mid-print, so I suspect the firmware update may be involved. I’m not sure if the fact that the object was from the last versions of PreForm/firmware, but I’m in the process of regenerating supports and re-printing using the latest.

I just had the biggest trouble after updating to the latest firmware as well. Printer would just crash every time I tried uploading a new file. I ended up installing the previous version of the firmware again and printer was fine.

Rebooting the printer usually sorts out problems after a firmware update.

Hey All!

If you continue to have issues with this latest firmware update, please reach out to our support team so we can help and figure out what’s going on to hopefully get the problem sorted both for you and the community at large! :slight_smile:

For what it’s worth, regenerating supports and re-uploading the print using new preform and firmware it worked fine. Not sure if it was the hard reboot or that, but anyway things seem fine so far.