Form 2 cartridge mismatch after firmware update

Hey there,

Yesterday my F2 started malfunctioning immediately after the firmware update (dated 20 Oct).
After the update, touchscreen wasn’t working, so I needed to unplug the F2 in the power cord.
After a reboot, everything seemed OK, until the first print: I am having the cartridge mismatch error every couple minutes, and after each layer the printer displays the info “Cartridge inserted”, which I think that never happened before.
After the error, I need to take partially out and insert again the cartridge, and it prints or a couple minutes again.

Cleaned the contacts both of the tank and the cartridge, didn’t work.
I tried a factory reset, didn’t work.
Tried with a new cartridge, of a different resin, with a new tank. Didn’t work. Same result.

Also, on Dashboard, I can’t see my printer, but I can send the files to print through Preform.

Any help would be appreciated.

Thank you all.

EDIT: After the cartridge mismatch error, I cancelled the print. Then restarted the printer without touching the resign cartridge, and it started recognizing it again. definitely firmware related.
Also tried to reinstall the firmware, and at the end got again the touchscreen stuck until I power cycle the machine. Reboot would not work. The firmware installs successfully though. And now I can see the printer on Dashboard.

Thanks for all of the troubleshooting you’ve done so far and I’m glad to hear that this seems to be resolved for now. Cartridge read errors are usually mechanical rather than firmware related but firmware issues are certainly something we’d want to rule out. If this continues causing issue, get in touch with our support team so that we can troubleshoot with you.

Hi Frew,

Thank you for your reply. I’ve already contacted Formlabs support.
The issue was not solved, just the dashboard started working again, but still can not print anything since i am getting cartridge mismatch error.

We have two machines at my work, one is about a year old and the other is brand new (about a month old).

Both are exhibiting the cartridge sensing issue after a recent (second latest - 1.14.21) firmware update. Putting the very latest firmware (1.15.4) didn’t help.

Edit: I should add - we can’t actually get anything printed as most items we print are 12-14hr prints that we do overnight. The system usually just ends up completely pausing the print thinking that the cartridge is no longer there, or in the best case, the print time blows out massively while it stops to sense the cartridge every few minutes.

We also had a resin dispense error on the older machine - where the motor appeared to stop working. We thought this was a mechanical fault but it turns out updating the firmware fixed that… go figure.

FormLabs - having multiple “failures” on different machines at the same time seems a bit unlikely from a hardware perspective. Are you going to get your firmware sorted out? Shipping replacement machines back and forth isn’t ideal for anyone (except the shipping companies).

Its very curious they way some percentage of Form2 users seem to have these firmware update issues and some dont. How can that bee if all the machines a basically the same. Why arent all the machines affected the same?

Updated the firmware yesterday.
My brand new Tough cartridge had to be un-plugged and re-plugged to be recognized during print start-up.
Also, after print completed and I opened/closed the cover, the screen became unresponsive on the print feedback page.

I have seen this issue recently too. Cartridge is fine, been used for tons of prints, then randomly during the print cycle it says the cartridge is not there, or that there is a mismatch in resin. Lift cartridge, put it back in and it prints just fine.

Hi. Thanks for the feedback.

I am still not printing at all. After removing and inserting the cartridges in order to keep up printing, last week the printer stopped recognizing any cartridge at all.
Support sent a new cartridge bottom assembly, replaced this week and the issue persists.
Today rolled back the firmware to 1.14 (which was working fine at that time) and still can’t print, since it is giving the cartridge mismatch error.

In fact, the printer knows that there is a cartridge inside, but doesn’t know what it is. This is frustrating, just bought 16L of black resin and 9 trays for a small production series and now just can’t print. Very disappointed.

Trying to solve this as soon as possible with the support team.
Will report back on news arrival.


Yuck. Good luck. You can look at this thread Form 2 LIfespan and look at Djkirkendall’s posts. The issue seems similar to me. His solution though ended up being a new machine i think.

This sounds exactly what I just went through, resulting in the $800 RMA.

Luckily ours is in warranty period. Just losing the stopping time here, for now…

Same issue here with an almost brand new machine (3 weeks old) not being usable after one week. Every few layers it throws the error and tries to sense resin thinking a new cartridge was inserted. This prolongs the build time enormously even if you babysit the machine over a 8-10 hour build. Support is sending us a new cartridge floor but coming via ground and is still several days away… so 4 weeks of ownership = 50% uptime.

Sorry to thear that… In our case, it did not solve the problem. Printer is going back to their HQ as we speak…
Good luck!

I am getting the same issue. An average 14 hour print job requires taking the Resin cartridge out and re inserting it every 30-45 minutes. Replaced the floor plate already too.

Worked for roughly 2 print jobs after the replacement and having the problem again

You will probably need to send back the printer…
Did this started after the firmware upgrade to de latest version?


Same issue here. I left it over night so it would restart the print after a while of the error coming up and then in the am the print was done but it went thought over a dozen errors.

Well, sounds like yours would keep printing after the error. Mine would stand still until somebody reinsert the resin cartridge…


Not anymore.

We ended up getting a replacement unit… too scared to upgrade the firmware - so everyone here has been told not to touch it.

Replacement unit has been going strong with 12hr+ prints every day or so since we got it.

Same here. Firmware dated April 2017. It has been running offline, just in case!

almost 3L printed with 100% success.