Form 1 + Motherboard not powering on

My Form 1 + is out of warranty and I would rather fix it and use it instead of it being a paper weight, I plugged the 24v dc supply in the printer and the board did not power on upon inspecting the board I found that the inductor labled L6 and the capacitor labelled C46 had became dislodged and were nowhere to be seen even after searching on my hands and knees and in the printer, tiping it back etc I was wondering if anyone knows the value of these two components?


I confirmed that the psu was not at fault as it was providing 24v as required.

Hi @chriskelly

If both of these components blew off the board, it’s likely that something more significant is wrong, and replacing them won’t fix things.

Still, it’s worth a try – here are the part numbers:

1 Like

Cheers, if they blew what components would have been damaged will the dc to dc converter be affected , what is the worst outcome say if the microcontroller got fried can the firmware be re-flashed etc?

It’s very hard to say, unfortunately. Those components filter the incoming +24V, so it could be basically anything downstream of that (which is everything in the printer).

I was wondering if you have a part number for the dc power jack?

The power jack is PJ-102A

cheers , is there a bom at all available so I can order anymore parts in the event they are damage instead of asking for every part?

We haven’t published that kind of documentation for the Form 1/1+. Once you’ve replaced the missing components, let us know how things are going!

Hi Matt, I have replaced the components now I think there is an issue with the galvonometer mirrors as when I run a spot test nothing shows on the piece of paper I have placed inside the resin tank area. I thought maybe the laser was broke but opening the printer and hitting the spot print option turns the laser on for about 10 seconds so I know this is not an issue. I checked the power on the port labelled galvo y-power and was getting just over 24v between pos and gnd and just over 2.5v for gnd and signal pin.

i have adjusted galvo mirrors and am now getting prints.

1 Like

I love it when folks start wrenching on their toys.

@chriskelly Great job! :wrench::man_mechanic:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hello, I have recently acquired a form 1 and the previous owner failed to his maintenance and the tank was effectively glued in place. That problem has since been resolved(mostly) but a problem stemmed from the mess that followed. Some fresh resin seems to have shorted my motherboard, with obvious damage to L6 and L7 plus one track. I can fix the track with some circuit writer, and I have the part for L6. I wanted to confirm the part for L7, if it’s different, and any recommendations for testing. The power supply should be good, but I would like to confirm I’m not over doing with that as well.

Yup, I can confirm that L6 and L7 are the same part.

Cool, now I have soldered them on (meh on the quality), verified continuity, and have seen power present on the back of the board throughout. But the motherboard is still not powering on. Any idea what might be the problem? Computer doesn’t sense it either, and the SD card is viewable if plugged directly into my computer.

Sorry, but it’s very hard to say – presumably, another component on the board has failed, but it’s difficult to guess which one.