Cure Station LCD Sleep Mode

While trying to update our Form Wash the Updater keeps getting stuck at “Preparing device to receive update”. Is there a possible solution to fix this problem?

You should definitely file a support ticket, so that we can keep tabs on the issue.

As a work-around, you can try the following:

  • Unplug the Form Wash or Cure from power, and wait about 10 seconds for it to power down.
  • While holding the front button down, plug it back in.
  • At this point, it should show up with a button labelled “Resume update” in the FormWashCureUpdater application. Press this button, and the firmware update should proceed.

Too bad it’s not possible to plug the Wash to the network or plug an USB stick in… or even daisy-chain it with the Form2, I now have to install PreForm on a laptop borrowed laptop just to update the Cure. Nice that we are finally seeing an update though.

1 Like

A version of this worked for me on both when it hung from my MacBook running El Capitan OS.

When it hung up I unplugged the power at the machine counted to 10 then plugged it back in.
The firmware installed and the machine restarted but the laptop hung on waiting for restart.

Unplugged the power at the machine counted to 10 then plugged it back in and poof, software recognized.

The same procedure worked for me. (Windows 7)

Thank you Formlabs!! The update worked perfectly for both my Cure and Wash stations, and resolved all the issues I was having with both.


Besides the sleep mode for the Cure, what other items did you add/fix to either with the update???

We fixed 3 bugs in the update (this is part of why it took a bit long, is we want to get all the known bugs fixed in a single update rather than multiple updates).

  • The Cure screen not sleeping
  • An edge case where the Cure screen could freeze
  • An edge case where you could end up with 3 options on the screen yet not be able to select the middle one (affected both Wash and Cure)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.