Form Wash/Cure updating problems (and solution)


#1

I just finished downloading the new version of PreForm with the firmware updates for the Form Wash and Form Cure.

I started with the Form Cure. After attaching it to my computer (Win 10) via USB, I ran the FormWashCureUpdater.exe (there’s no way to launch from PreForm; the “What’s New” popup when launching PreForm has a “learn more” about updating the firmware, but this just opens a generic page related to the Wash/Cure rather than the page with specific instructions.)

Anyway, my Form Cure was shown in the list, I clicked it, a small window opened saying that it was preparing the Form Cure for the update… and then nothing. After waiting 15 minutes, I gave up, closed the app, and restarted the Form Cure (unplugged power cord, waited a few seconds, plugged back in).

Retrying the update produced the same results: “Preparing…” forever.

There is a solution however, so if you are experiencing this problem, this is what worked for me:

After starting the updater, select your machine (Wash or Cure, worked for both of them in my case), wait for the window with the “preparing…” message. Wait a few seconds, then close that window via the X in the upper right corner of the window. Now re-launch the updater immediately (don’t reset your device, power it down, nothing),. This time the button on the updater should say “Resume Update”. Click that. It should immediately begin to update your Wash/Cure (the progress bar should start moving right away).

(Also, incidentally, the updater gets stuck in “Waiting for device to restart” forever, long after your device actually restarts. In my case, I just waited for the device to actually restart (the LCD panel to show the main menu) and then closed the updater window.)


#2

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.