Chat support isn't an ideal design

The chat function on the support website isn’t very well thought out.

I’m in a queue waiting for support, when they do respond, they send me a link for things to check, I click on it and it opens a new page and closes the chat window.

Now I’m “disconnected” and I have no idea how to get back into chat.

How do I re-access the chat? If this is the design. It’s… not optimal.

Yep, probably not ideally coded ( target="_blank" or lrn2JavaScript :wink: ).

Pro-tip for the future. When unsure if a link is going to open a new window (and you want it to) hold down Shift on the keyboard and then click. It will force a link to open in a new window. (I’m pretty sure that’s valid for PC and Mac as well).

Re-access just by reloading or going back to the original window.

Lastly they are a relatively small company and it was about their lunch time when you tried (approx 1pm). Maybe try again now or soon!

It’s kind of frustrating sitting here with a pro service plan and be dead in the water.

Chat was the quickest response time I had to my issue but I can’t even find a way to start a new chat session now.

It is probably cached your browser either that it is open and you cannot see it, or that you already chatted and it is over. Perhaps close your browser and/or clear cache and try again.

Also, since you have the pro service plan as I do, have you tried calling them?

@MakerKurt, I have had really good luck just calling them. I have the Pro-Plan as well. I believe I left a message and they called me back within an hour.


I left a message over an hour ago… maybe 2… I got a million questions on things that is being left out of the setup instructions. Can I patch firmwire over USB. If so where do I find the drivers for the printer. Can I patch firmware over ethernet? That works but I can’t see to patch firmware.

Does the form 2 build trays have a plastic protector on the bottom to peel off? I saw no steps for that but I’m seeing references to it in posts here [maybe form 1 setups?] I just unwrapped the tank and took the lid off and installed it and the wiper.

I’m getting conflicting answers in my email about a motors binding issue… I haven’t done anything yet, one email tells me to go ahead and just finish setup and print and another one saying the printer has to be replaced.

I’m pretty much confused at this point.

1 Like

Well if you want quick results you can always post your questions in the forums. Most regulars here can answer those questions for you :slight_smile:

The Firmware can be upgraded via USB (preferred method) and over wireless thru the UI on the printer. Check out info here. Here is a direct link to the current firmware, version 1.11.7 for the Form 2 dated 12/19/2016. You can always read the newest release notes and download the newest firmware here.

The resin trays do not have a film or protector on the bottom. Just peel off the shrink-wrap, remove the black cover and pop it in the machine along with the wiper. Remember not to touch the bottom of the tray, however, once the shrink-wrap is removed.

Regarding the motors and printer needing replaced…I can’t help ya there! Have you completed a successful print yet? or are you setting up for the first time?

I got the call back so everything is sorted out.

The firmware I had to update via manual download, and it works fine over ethernet. They will be updating the interface on the printer and Preform in the future to indicate both USB and Ethernet connections will work for this. That USB message was throwing me off the trail.

The film on the bottom of the build tray was a new item but the Form 2 tanks don’t have anything beyond the lid and the shrinkwrap cover. I guess that could be a thing for 3rd party trays and doesn’t apply to me in this case.

The motor issue was related to an order of operations problem in the quick start guide. I plugged in the printer in an early step which booted the printer, but before I was able to install the wiper and Tank, I was getting a binding noise, I tried going ahead and installing everything else [tank wiper and resin] and that problem went away, no more errors. The error could mean a Z axis problem or “something else isn’t” installed problem, the error message will come up for either case.

I’m about to run out a few test prints right now and see how things go. But I think all my questions are answered now.


Good tip! Though Kurt is absolutely correct that links in chat should by default open in a new tab. They should fix that.

I’m in such a habit of middle-clicking links (open in new tab in Chrome/Firefox) that I sometimes forget links also work with LMB. =P

1 Like

I completely agree. No user should have to even think about losing their chat window to a provided link!

Awesome! Let us know how your first print goes!

Hi everyone,

Chat is a brand new function that we are currently trying out in order to see how it can improve the support experience. It is only shown to a handful of customers right now (that’s probably why you didn’t see it again when you re-opened our web-site) and there is a ton of room for improvement. So our apologies for your experience and please don’t hold back with any feedback like this. We are working hard on making the chat experience a great one.

We are looking into changing the behavior of links or having the chat open in a separate window.

Any other feedback on your side that you think we should incorporate?

Also, please let us know how your first print came out!


You guys rock, thank you @Sebastian_Fritz.