Build platform stuck

I just received my Form 2. I set everything up, removed the valve cover from the resin cartridge, inserted the cartridge and submitted a print job. The printer started heating up but the resin never filled the tank even after reaching the needed temperature. So I tried everything: I removed the cartridge multiple times, I restarted the printer and in total tried to print three different models - nothing, no resin flowing!

However, the even bigger problem is that every time I started printing a new model, the build platform lowered itself by a couple of centimeters but never rose again, not even after cancelling a print job. After the third attempt of printing, the build platform is now so low that it is stuck inside the resin tank and I cannot remove either the resin tank or the build platform!

I also submitted a ticket (ID: 67720)!


I managed to carefully disassemble the build platform and the resin tank without (visibly) scratching anything. However, the build platform still does not move and when I now try to print something it just displays the error “Failed to start print”!

Btw, I also update to the newest firmware without success!

I can’t help with the platform but for the resin to come out, you just have to squeeze the rubber valve open by hand once. Do it holding the cartridge upside down (obviously). Some cartridges work without that but in some the mechanism will not open the valve unless first opened manually.

It seems to take a while for the resin to first come out…
If you do flip over a bottle to mess with the rubber seal, remember to close the cap first. :wink:
I like to dribble some of the resin into a new tank before I start… lets the wiper slide better.

Since it got stuck has the machine recalibrated?
Have you unplugged it and plugged it back in?

Open a support ticket…

The machine never recalibrated or moved the build platform up in any way. Can I somehow trigger that manually?
I can’t move the build platform by hand and also don’t know if that would be such a good idea…

I unplugged it multiple times and tried a couple of different models - to no avail.

I’m also running the newest Firmware and Preform and opened a support ticket.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.