When will we get a new Preform version compatible with complex meshes created in Zbrush


I spent the entire day trying to optimize/clean/resize meshes created in Zbrush and checking the layers in Preform. ( I used Netffabb and meshlab and have no error there)

Each time I manage to find bad layers that will end up to create shifted layers and depending of the scale of the objects the bad layers show up at different layers for the same objects.

While ago the issue was visible on the white walker bust that FORMLABS printed.

I would be very happy to try any other beta version of the Preform with any fix for that.

I hope we won’t have to wait weeks for another version of the software because some people want some feature that are not related to precision and quality.


I don’t have my printer yet, but i hope they will fix this as soon as possible … This is really shame to be limited by the software

It would great to see some screen shots of these layers in preForm!


There are some images on the 3rd comments from me.

the new version of Preform still doesn’t for me

Magics RP -> http://software.materialise.com/magics by Materialise is what I use on all my clients 3D files.  Most RP shops use Magics if they are serious about providing 3D Printing services…  Applications like Zbrush, Rhino, Sketchup, Maya are not the best 3D design tools for creating 3D printer content since they have difficulty in providing the watertight poly-mesh that 3D Printers require,  They are excellent for creating organic like objects,  then the derived content is imported into Magics RP to sanitize  (flip triangles, repair holes, removed multiple shells, etc…)

Unfortunately Magics is priced out of reach for most DIYers, but there is a free version of Magics (minimagics) that will show you where the errors are -

-> http://software.materialise.com/minimagics

Best regards,


John (jay) H. Morewood

Owner / Rapid Prototyping Engineer



Thanks Ferret7

I will try since I cleaned my mesh in netfabb and meshlab and Preform is not telling that my mesh is wrong

It might be a printer issue. Were printing similar heads here out of zbrush with no major issues at all.

It s not a printer issue since it s in the software that you see the errors.

Have you primed your print and how big are you printing your mesh

The 1st file I was testing has more errors showing in the preview than other mesh but I didn’t try to reprint any since Formlabs is looking in the issue.

If you have any photos showing your print that would be nice to see ( If you have a very noisy mesh maybe it s less visible than on an smooth one)

I have attached a couple images of the results I am getting. There are some errors/artifacts, but it is manageable enough for cleanup. It would be nice to have some of those little artifacts gone though! I am not sure what errors you are seeing in the software? For most of my models, I run them through mesh lab, delete non manifold geo and then run the fill hole tool. It has been pretty successful.

Thanks for the photos

The errors I am getting are visible by checking the layers one by one as you can see on my last picture ( the surface looks wrong on that layer)

As for your mesh you have few layer shifting visible but your stuff looks great how bit it is 1/6 ?

Thanks! I never used the layer checker much. I will give that a go next time. The print is 4/35" tall. I also hallowed out the inside, that’s why his face looks really strange in the clear one, you are seeing little cracks and extra resin in there. One thing when printing is orienting the model at an angle usually helps. Also never use the default support structures. I set mine to the max spacing and make them a tad thicker.

Wow Robert! That absolutely is beautiful stuff there! The paint makes it look like stone, great job m8!

Here is an example that make no sense to me:

I was checking the layers of something I wanted to print since I am waiting for an update of the software to fix the layer shifting and my mesh was showing just an error at one spot.

Then I created the support and guess what I have layers errors that appears in a new area…Please Formlabs update the software.

Thanks, Julien. These are really useful. Zbrush models present a lot of slicing challenges, but we’re aware of them and are working to find fixes.

If you decimate the model, do you see the same issues? It could have something to do with the number of polygons that Zbrush creates.

Can you recreate the issue on a simpler sculpt? That’d be really useful for our development team. If you can forward the .STL to support@formlabs.com, that would also be really helpful. We’d use it only to debug, of course, and destroy it after.

Hey Sam

I am pretty sure that in the test files I already shared with you the sphere is a quite low poly mesh.

And I am saying it again but those errors are not limited to Zbrush but objects made in maya have some layers errors showing up too.

I will try to decimate one of the mesh but I already did that test before maybe I need to decimate it more but to me it sounds that the slicer is fast but maybe to fast ( I wouldn’t mind to have a more accurate slicer option so if it takes few minutes to have an object sliced at least the slice is error free ).

Hope to get a software update soon


Robert -  your print was 4/35" (.11 inches tall)?!

No sorry 4.25" :smiley:

more print that I made here:


Still having layer shifting even with maya files

The last on from Zbrush was decimated.

Hey Robert, very nice sculpt and printed material!

Only one question: How much liter material were used for this model? and is this a Formlab type Clear Resin material, is it?