Preform 2.12.3 for MAC and still having problems with supports in newer Preform versions

Hi everybody,
We still have the same problems with the newer versions of preform (see closed post):

Downgrading to 2.12.3, we do not have any problems anymore. Furthermore, latest 2 firmware versions (that improve printing speed) do not fulfill our surface finish requirements.

For all the above mentioned reasons we are using older versions of Preform and firmware and we are worried about the future because it is supposed that there will be incompatibilities.

Do you have any news about this?

Could you send us Preform 2.12.3 for MAC?

Waiting for FL answers.

Best regards,


1 Like

This tends to be related to the mesh itself, though the behavior of the supports in the earlier thread is strange. Are you noticing this behavior on all models? You might try generating supports on a third party model to see if it produces the same issues.

I’m on a Mac as well, I only do about a print a month, so my Form 2 is lightly used. I have only ever had one print fail in over a year, but since installing 2.14 I have not had a single successful print. It prints the base onto to bottom on the resin tray and that’s it. Never even gets to the platform.

Hi again,
We are a 3d printing company, specialists in footwear industry. We design our 3d models and print other designed from our clients. The majority of the designs are very detailed with lot of textures and we need smooth surface finish. All designs are checked using magics software. We also use other technologies like Polyjet and FDM. Hundreds of models printed with no issues (regardless the typical ones). Like other industries, timing is critical and some meshes have triangles inside the volume, but no open or bad edges.
We do not understand why newer versions from 2.12.3 have the issue mentioned, probably a change in the code that is more sensitive to that. it happens in about 80% of the models.

Other problem is the surface finish, 2 Form 2, same models, and with the latest firmware (that printing times are improved) layers are more visible.

At this moment, downgrading firmware and software is the temporary solution that we have found.

Anyone else has these problems? We are very worried about that.

Best regards,

In the earlier thread, it looked liked there were some internal triangles causing issue based on the layer slider. Are you seeing that same behavior here? If you’re able to send over some of your problematic form files, that would be a big help in troubleshooting this.

Hey. Same problem here. Nothing works!!!
I’ve had my FL2 since new year, initially has worked great and I’m over the moon with the quality. However about a week ago I had a failure, so I updated all software and firmware, changed resin and tray. My success since then has been 0% and I must have tried about 20 prints. I have tried reinstalling the software, adjusting the x axis. I cant seem to work out how to install previous software as I cant find any links. If there is a problem with the software for a mac then it should be addressed by FL.
I purchased this machine to help with my prop making business and now has become a massive head ache and waste of time.

Thanks for all of the troubleshooting you’ve done so far with the axis tuning and by trying new tanks and cartridges. No successes over 20 prints sounds especially frustrating, and our support team is going to be best suited to help out with this if you could open up a ticket. We keep a close eye on issues associated with a given firmware and your ticket will be a big help in making sure that the firmware is working normally, and it’ll allow us to look into the root cause of your print failures.

I’m in touch with support but still no luck. Not really impressed with the time it’s taking to get this sorted via emails.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.