Very slow file transfer over Ethernet

I notice that when transferring files to my form2 over Ethernet, it is VERY slow (i.e. can take several hours), while by USB the same job happens in a couple of seconds.

Any thoughts on how this can be speeded up?

When you say Ethernet, is your printer hard wired, or are you sending over WiFi? Also DHCP or static IPs? Are you in a large corporate environment or a small home network? (Not trying to be nosy, but trying to eliminate further troubleshooting questions.)

Hard wired printer, not wifi. Static IP given. A reasonable sized network (University).


Thanks for the info. Not being a network administrator and not knowing your university setup I really won’t attempt to troubleshoot further. Perhaps someone else has had a similar issue and can comment. That being said I would say with relative confidence you have a networking issue as opposed to a printer issue.

I would open a ticket and work with FL support and your network admins to further troubleshoot.

No, I don’t think its a network issue, but one with the printer.

Do other people manage to print okay over Ethernet?

I have printed over a corporate network via WiFi very successfully for the 6ish months I’ve had the printer…I believe many others do as well. And as you can imagine your experience is not normal…sending a print for me over WiFi takes a matter of a couple minutes max. I can think of 2 other threads with similar issues but both were WiFi.

Of course I cannot completely rule out the printer as the problem, only FL tech support, possibly with the help of your network admins, can assist.

EDIT: The only other thing I can suggest is a factory reset of your printer. Enter your network settings again and give it a go.

Hi! I also noticed this since the last PreForm update. It used to be fast over ethernet and now has become painfully slow. To the point I prefer saving the job onto a usb stick and taking it across to the printer computer and print from usb. It’s the PreForm 2.10.3 on Mac Osx Sierra.

So I guess I am seeing the same thing you guys are, however I don’t think it is network issues. I hit print and it says “Generating print files” which looks like its going to take about 30 - 45 mins. I could be wrong but I don’t think the file is actually transmitting to the printer. The printer is not indicating it is receiving a file (yet). There seems to be a bug in the “Generating print files” function of Preform.

Edit: of course I am using the latest and greatest, preform 2.10.3 and firmware 1.12.10-85

What is your transmission distance??? I can tell you I just diagnosed a failure in communication due to distance (likely attenuation) issues. Ours wouldn’t upload any job whatsoever but could see the printer. Attaching a generic switch in between solved the issue completely. FYI, this was a 150ft+ run with no option to change the placement. It’s possible that the NIC used in the printer design is not up to spec.

In my case as the crow flies its about 40 ft. (through two rooms and a hallway. I have had this printer since June, absolutely no changes to my setup with 0 transmission problems until I updated to the latest software/firmware to test for this thread.

Also need to reiterate (in my case at least) the “Generating print files” portion of uploading the print took about 25 mins. At about the 50% mark it changes to uploading print which took about 45 seconds.

I can’t think of anything that changed recently that would have caused this kind of slowdown. But I did want to mention one thing you should probably check. When the printer’s internal memory gets very full, it can behave like this. You can check this by going into “Your Printer” -> Settings -> Storage (it’s all the way down at the bottom). If there’s very little storage left, you could try removing some jobs and see whether that helps.

I’ll ask around some more and see if anybody can think of any recent changes which might have affected upload speed.

I just checked my printer, had approx 1.5gigs of prints on it. I cleared the memory, restarted the printer and then sent the same print that I did earlier. Granted it is a large print, (full platform, lots of layers and supports) but I have sent this exact same .form file before and, while I never timed it, I don’t recall every waiting this long for a print to go.

I waited approximately 6 mins between hitting the print button and grabbing the screenshot.

At least for me It does seem to be complexity related. I deleted 3 of the 4 items on the platform and resent the print and it took about 4 mins.

OK, that slowdown only happens when the free storage gets really low. I just wanted to make sure you checked, since it’s an easy one to fix. As I said, I’ll keep checking and see if we can find something that changed recently which could be affecting upload speed.

@mgarrity So I tried one more thing. I uninstalled Preform, deleted the remaining Program Files directory and deleted the associated AppData folder…then rebooted my machine (which I admit has been a couple of weeks). Window’s 10 BTW.

Reinstalled, loaded up same STL file, duplicated 3 times, built same supports. This time (using a timer :slight_smile: ) my generating time was 5:30 and sending file was 90 seconds. More along the lines of what I would have expected.

So in my case could have been a local computer problem, .form file issue? IDK but my case seems to have dramatically improved. I hope the others get their situations cleared up as well.

Thanks! I’m not sure what that’s telling us, but it’s useful information.

1 Like

I tried reinstalling (deleted using AppCleaner to make sure no libraries are left behind) but still get stuck at sending to printer. In my case the file generation is normal, it’s really when it gets to sending to printer that it gets stuck.

OK, my bad!
I just finally pinpointed it’s a network issue at my work place - tried installing a previous version of preform that I was sure to work properly and had the same issue. Then started troubleshooting the network speed and the uploads were down to a crawl. So, not a PreForm issue at all in my case.

Well, looks like you (@jpt000) and I are squared away :thumbsup:

@agb32 ? Still having issues?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.