Ethernet Slow/Unstable Compared to USB

We have a Form 2 printer that we have had hooked up through USB. Recently we went to set it up over Ethernet and encountered some issues. Our network issues addresses over DHCP that we first manually assign to a MAC address. This has worked on pretty much every device we have ever tested it on, but the Form 2 never received an address. Manually setting it sort of works, and it is now pingable and seen in the software as a valid print target, but its so SO much slower to send. At Least 10 times slower than USB to send the same file, Trying to update firmware through ethernet doesn’t ever even progress to 1%.

Each ethernet port tests fine and also works for other devices so it isn’t bad lines/runs.

Is this normal or should we be looking at some kind of warranty repair/exchange?

What you are experiencing is not normal. I have mine on WiFi and it takes anywhere from 20 seconds to a min to send the print. My network assigns via DHCP as well and has no issues picking up an IP address. You can try performing a factory reset on the printer by performing the following steps.

To perform the factory reset:

Unplug the printer from power.
Reconnect the printer's power cable.
Press & hold the printer's button until the touchscreen re-appears (around 15 seconds).
Release the button.

If the reset has been successful, you will notice that the uploaded jobs list on your printer will now be empty.

I would definitely open a ticket so you can troubleshoot it further, especially if you are having problems after a reset.

  • Kevin

Thanks! Ill definitely fill out a ticket. I just did the reset procedure you outlined and I thought it fixed it, it was able to immediately receive the ip address through DHCP unlike before, but its print time is still way too slow. a Job that sends in 10 seconds takes a minimum of 5 min to send over through ethernet still.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.