Touchscreen stuck on initializing screen


#1

I went to use printer and noticed that the touchscreen was frozen. I tried rebooting and the screen got stuck (frozen) on the butterfly logo initializing screen. I unplugged again and left it off for a minute and tried again. Same result. I factory reset the machine with same result. I left unplugged for 15 minutes and tried again with same result. Any suggestions? (Sent in a support request already. Just seeing if anyone has experienced anything similar.)


#2

I’m in the same situation. I’ve submitted a ticket and it’s been two days and I haven’t heard anything from Formlabs. Hopefully, your machine is back up and running more than a week later.


#3

Support had me try a few things including reseating the ribbon cables to the LCD screen. Didn’t help the issue. My machine was still under warranty, so they sent me a replacement machine that arrived yesterday. Hooked everything up and I am back in business. Hopefully, you will be back up soon!


#4

Thanks for sharing your news. We’ve had our machine for just a few months so still under warranty as well. Hoping it’s just a ribbon cable but that doesn’t make any sense to me, the screen is working and showing the initializing screen. Anyway, it’s some comfort to know I’m not the only one experiencing this issue.