Formlabs Website Store Support

Tank Position Error

Hello everyone, long time lurker, first time poster.

After a long period of not being used after a resin spill (bad cartridge valve), I have taken the case off and cleaned out the resin. The printer seems to start up just fine, the tank moves to the left and the right with no issues during the start up sequence. Once I uploaded a job and started printing, the tray moved all the way to the right instead of the left for filling and warming. While filling it tried to move the tank, you could hear the motors knocking before the wiper moved. It stayed there when the build platform came down into the tank (so the build platform was at the extreme left end of the tank, not centered over the window) and then after it finished the first layer it tried to slide further right to peel the print off of the PDMS, but since it was already over as far as it can be the motor knocked badly for a few seconds, then the build platform lifted straight off. I canceled the print at that point.

I took the case back off and double checked that the limit switch was clean and both ends of its wiring were firmly connected. I hadn’t noticed any resin in the limit switch during my cleaning, and closer inspection didn’t reveal any obvious issues, but the problem persisted.

It seems like everything would be working fine if it started a job by indexing to the left side as normal, but it is not and proceeds like it is.

Has anyone seen this issue before, or have more ideas on how to fix it?

Thanks!