Spacemouse no longer working in Preform 2.15

Today I upgraded Preform to 2.15. Now my 3DConnexion Spacemouse no longer works with it. I recently downloaded the latest 3DConnexion driver (3DxWare 10). I had not used my previous release of Preform since upgrading that driver. So I can’t be sure where to point the blame.

Yep, using 2.15.1 and it does not work for me either.

My 3DConnexion Spacemouse mouse never worked in the earlier version.

My Spacemouse no longer works with the latest version released in March 2018. GGGGGRRRRR!

The latest versions of the Spacemouse drivers were 10.5.6 for PCs and 10.5.2 for Mac. both were released 3/18.

I just checked and my driver for the Space Mouse on my PC, it is Ver. 10.5.3…and it does not work with 2.15.1 Preform. The S.M. did work in several prior versions of Preform…seems the problem lies with FormLabs.

Our software team is currently looking into this! Thanks for bringing it to our attention. For anyone interested in using a 3D mouse right away, Formlabs Support can offer a temporary fix. A link for creating a support ticket is on this page:

I had the same problem as you did. Updating the space mouse drivers to the March release fixed it.

Just updated my drivers from 3DConnection’s website, latest for Windows, 10.5.6…Still no luck but it was worth a try, thanks anyway.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.